Showing results for 
Search instead for 
Did you mean: 

ASUS ROG STRIX Z690 I-gaming WIFI GPU and iGPU issues. HELP!

Level 7

Hi guys, i recently bought the ROG STRIX z690 i gaming wifi for my SFF pc build. The thing is that i ran into some problems.

I updated the bios using the biosf lashback to the latest version. I installed the Thermalright contact frame, and cpu (13600K), ram and all that jazz.
First problem i ran into was that the board does not see my RTX 3070 (which works fine in the other PC, so it's not the gpu). I tried it with riser cable and without the riser cable, still no go. I've set the pci speed to gen 3, nothing. 

After all this i tried to install windows 10 using the iGPU. Al nice and smooth but as soon as i install the intel graphics drivres, the screen turns black and i can't do anyting. I restart the cpu, go into bios, everything looks ok, then as soon as it boots into windows, the screen goes black again.

I tried to roll back to an older version of bios, but that doesn't seem to work. Tried it with EZ flash tool but it says that it's not a proper bios file, then with the bios flashback tool but the led stays green and doesn't want to initiate the update.

I was wondering could this be because i tightened the contact frame too much? Or the pump head of the aio? I am trying to rule out any possible mistake that i might have done. So please if u have any advice please help me out. Thanks.

PC specs:

Lian Li A4 H20 / ASUS ROG STRIX Z690 I-gaming WIFI / 13600K / 32 gb DDR5 5600mhz cl40 Kingston Fury / Seagate Firecuda 520 2TB SSD / Corsair SF750 PSU / 240 ID Cooling AIO/



Level 7

Try to remove thermalright frame first. The frame could randomly influence RAM & PCIE lane when installed too tight or loose.

Level 7

Right now i'm working on that. Thanks