Showing results for 
Search instead for 
Did you mean: 

Asus ROG STRIX Z690-F - ALC4080 Long Time Issue Still Not Addressed? What a joke!

Level 8

I am so sick and tired of Asus and the customer support acting like they give a crap about their customers. How many countless issues on the ALC4080 causing audio clicking and popping sounds. Yet they still refuse to do anything? It’s been around 2 years now. I will never buy an Asus product ever again. Typical greedy and selfish type of people and company.

I don’t need to do any diagnosis as there is a whole Reddit and forum flooded with the same audio issues and it is clearly not anything to do with the customers. Yet they will try blame it on us. Asus motherboards with ALC4080 has been causing this audio clicking and popping when you stop and start sound, when you reboot it will make clicking and popping sounds, when you lower the volume and raise the volume fast it will click and pop. I don’t need to explain there is countless posts about it. Yet Asus doesn’t care they are greedy and selfish and just want to rip off their customers. It’s in their culture lol. 

Asus if you really do care about quality and customers then address and actually fix this issue? Your useless PD update does nothing either probably doesn’t even do anything and just blank code lol. So sick and tired of the problems customers are having but Asus never address them. Not to mention your products are overpriced and this is what we get? 

- Anyone else with the Asus Z690-F experience this problem aswell? Have you found a fix? I make music and I cannot stand having this clicks and pops. I am ready to throw everything of Asus in the bin. Literally.

- To other affected customers has anyone here bought a music production usb audio interface to replace this crap ALC4080? If I spend money on a music production usb audio interface will this clicking and popping stop? Anyone tried this?

Last time I ever go with Asus again…. The company don’t care and the support is useless….. Typical of these type of company…


Level 11

PD update? that has absolutely nothing to do with the alc4080. PD means power delivery lol....calm down and actually tell us what the problem is. this is the first im hearing about it.

Super Moderator


Not really a lot to go on. Issues with the ALC4080 codec don't seem to be motherboard vendor specific.

Which codec firmware are you running?
Which codec driver?
Which UEFI revision?
Which output are you using? SPDIF, 3.5mm?

Have you tried any of the fixes mentioned here pertaining to the Realtek driver?



13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090