cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG STRIX Z690 BIOS 2305

arlicht
Level 9

Hey guys,

Anyone tried new bios 2305? Any thoughts?

37,729 Views
188 REPLIES 188

If I download that, will it work on my Z690-e?

Lkcraig73
Level 7

Will any of the bios updates for 2403 work for the z690-e or are these udates specific to the model they are posted on?

You need the specific BIOS created for your motherboard. The core code might be the same (I assume), but unless the correct version for each board, they will not install.

Z690 Hero, BIOS 3401, MEI 2406.5.5.0, ME Firmware 16.1.30.2361, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Zardoc
Level 10

I haven't seen any difference in performance for the last maybe 5 bios updates.

Boot times compared to my Z390 are way slower. It's a drag when you expect faster boot times on a newer board and it's the opposite. Seems like MSI boards boot way faster. Might give them a try even if I said I'd never buy another.

Never say never

Gothic
Level 8

Hi guys, there are new bios 2602, solved problem with xmp, my gskill z5 6600 goes another time at 3300mhz(6600 real) and suports news procesors, i supose 14th gen, sorry for my bad english... hurry up to update...!!!!! it's stable for the moment... jijiji

Gothic
Level 8

Sorry my mainboard is Rog Strix Z690-F

naulito
Level 9

The BIOS 2305 left me a very bad experience. I am afraid to update to the new BIOS 2602. I think I will wait a couple of weeks for more users to share their experience.

Asus ROG Maximus Z690 Hero Motherboard - Intel i9-13900K - Asus Thor 1200p - Kingston Fury 128GB (4x 32GB) DDR5 4200MT/s (Trying to run 128GB at 5600MT/s) - 3x Firecuda 530 NVMe SSD 1TB - WD Black SN850 NVMe SSD 2TB - ASUS ROG STRIX RTX 4080 - Windows 11 Pro x64

mapotter99
Level 8

I just installed 2602 on my Formula Z690.  Everything works fine until I turn on XMP and it throws blue screens at every boot attempt.  I'm using four 16GB sticks of Corsair Dominator Platinum DDR5 5600.  Same as before.  Prior to this winter's awful BIOS update, XMP worked fine.

Corsair dominator are a pain in the Azz, replace with gskill with hinyx chips, i update to 2602 and works like a charm i have 32gb gskill z5 6400mhz with xmp enable, y-cruncher passed without issues and memtest has succesfully the 4 passes approx 1hr test., My mobo is z690 maximus extreme with 13700k. You can try with 2 stick, remeber that z690 had some unstability due to poor IMC on z690 pch.