Showing results for 
Search instead for 
Did you mean: 


Level 9

Hey guys,

Anyone tried new bios 2305? Any thoughts?

188 REPLIES 188

Thank you for contacting Asus. So can we hope that the next update will be released and the problems of 2305 will be fixed? This is really troublesome. Unfortunately, it is not possible to return to 2204. Unfortunately, Asus did not mention in the description of the 2305 update that it is not possible to return to the previous version.

Level 9

Hello. I am writing my experiences about Bias 2305:
I installed this new version of BIOS 2305 for Z690-F wifi gaming. Compared to the previous version (2204), this version does not have good stability for XMP activation. In fact, by activating the XMP, the system becomes unstable and after a while Windows freezes. I hope this problem is fixed. Unfortunately, this version of bias is not suitable for overclocking activation. On the other hand, it is not possible to return to the previous bias and previous versions (2204) of the bias are not recognized. I think we should wait for the new version of Bias in the future.

Level 8

12900k, Z690 Hero

My Computer was perfect in the stabilit till this f u c k i n g Bios 2305 !!!! XMP Problems by Memtest!!!! Windows BSOD ! 
We cant downgrade… Maybe my Last Asus Board…

Level 17

Hmmm, why on earth does ASUS not say it can't be downgraded on the support page. I couldn't downgrade either (I only tried EZ Flash, but I don't think the Flashback port would make any difference). 

Z690 Hero, BIOS 3401, MEI 2406.5.5.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

I try it, its not possible

Level 9

Hi guys. Does any of you know if the ASUS team is aware of all the 2305 BIOS malfunction comments on this forum?
I think there is already quite a considerable amount of bug reports, I think Asus should comment on this bug.

Asus ROG Maximus Z690 Hero Motherboard - Intel i9-13900K - Asus Thor 1200p - Kingston Fury 128GB (4x 32GB) DDR5 4200MT/s (Trying to run 128GB at 5600MT/s) - 3x Firecuda 530 NVMe SSD 1TB - WD Black SN850 NVMe SSD 2TB - ASUS ROG STRIX RTX 4080 - Windows 11 Pro x64

Level 8

I Think that is my last Asus Board.

Today the Support was like amateurs

Level 9

All, I have a case in with Asus on this issue and I'm still waiting to hear back.  Ticket was opened on March 27th and they keep telling me that they are looking into this and have sent it to the higher tier of support.  Spoke with a supervisor yesterday and they asked me if I could turn off the XMP and I replied with "no" because, quite frankly, it was fine before the BIOS update.  I will absolutely be sure to share the response from Asus if/when I get one.

I also wanted to mention that when I updated to 2305, I noticed that after powering back up, my Intel X710-T2L network card stopped working (I use external because the onboard is trash) on the first boot up.  After powering off and back on, it started working again.  Not sure if anyone else saw that strange behavior or not, either, as I had not experienced that on previous BIOS updates (connected via PCIe).  Further, when running AIDA64's stress test, the graphics card is now failing when prior to the BIOS update, it wasn't.  Anyone else experience any anomalies with PCIe devices?

Ryan Blake - IT Leadership Professional
Asus ROG Maximus Z690 Hero Motherboard - Intel i7-12700KF - Corsair RM1000x - Corsair Vengeance DDR5 RAM 32GB (2x16GB) 6400MHz (CMK32GX5M2B6400C32) - 3x Samsung 980 Pro SSDs (1x 1TB & 2x 2TB) - eVGA GeForce RTX 3080Ti - Dual Boot Windows 10 Pro x64 & Manjaro Linux (Arch-based)

Hey friend,  i had today the same problem. I think firstly the problem is my Switch. When you have the same problem with the network controller then im not alone

After updating to BIOS 2305 on my ProArt Z-690 Creator WiFi, I noticed that after powering back up, my Thunderbolt 4 ports stopped working.

If I do a Windows Restart, my Thunderbolt 4 connections work.

So basically, I have to power on. Boot up to Windows 11, then Restart Windows. I have to do these steps daily to get Thunderbolt to work. I have the latest Intel ME firmware, INF Chipset and Intel ME drivers.