cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Prime Z790-A WIFI. How to enable/activate the Rear Panel Ethernet Port

Panagiotis_Mela
Level 9

Good day to the community again.

In connection with a previous post of mine (https://rog-forum.asus.com/t5/intel-700-600-series/asus-prime-z790-a-wifi-selecting-the-appropriate-..., I am again asking for help from the community.

As I have already written in that post, my Prime Z790-A WIFI has been initially set on a Test Bench (the Cooler Master Test bench V1.0), as a preliminary preparation step, of building my new PC.

Firstly, I installed the ADATA XPG GAMMIX S70 Blade M.2 NVMe 1TB SSD in the M2_1 slot, using the M/B heatsink, as advised. Next, I installed the CPU in the LGA 1700 socket and the Arctic Freezer 34 eSports Duo CPU Cooler. Consequently, I installed the Prime Z790-A on the Test Bench and I installed thw 2 DIMMs of the G.Skill Trident Z5 in the A2, B2 slots, as recommended in the manual.

Then, I connected the necessary cables from the Corsair RM850x Shift PSU on the motherboard, I installed an Asus GeForce GTX 1050Ti OC Expedition Graphics card in the PCIe 5.0 x 16 slot, I inserted a USB stick, containing the new BIOS version 1010. I started the system, I went directly to the ASUS EZ Flash 3 Utility and I updated the BIOS succesfully to the new version.

Then I shut down the system, I removed the USB stick, containing the new BIOS and I inserted another bootable USB stick with Windows 11.

I restarted the system and after setting a few parameters in the new BIOS (not all of them - I confess), including the selection of the first boot device (giving of course the USB stick as first device), the system went directly to the installation of Windows. A few steps later, the progress of the installation asked me to proceed to the dowloading of the latest updates, but it seemed not to recognise the connction to the Internet, through the Ethernet connection, where I had already connected an Ethernet cable to my house router.

I tried to find a relevant setting of activating/enabling the LAN connection in the BIOS manual, but I could not locate it. I am not sure if there is such a setting or the LAN connection is activated/enabled by default.

Any help will be highly appreciated.

I know not with what weapons World War III will be fought, but World War IV will be fought with sticks and stones
Albert Einstein
5,621 Views
5 REPLIES 5

JohnAb
Level 17
 

Do you have the ethernet/LAN drivers installed? I've included a list of the current drivers for my board, but check your motherboard support pages and also MoKiChU's drivers thread here:

https://rog-forum.asus.com/t5/hardware-build-advice/index-all-my-firmware-drivers-software-threads/m...

download.png

I like to keep up to date with all of MoKiChU's drivers and I have no issues.  You didn't mention if you have installed all of the Asus drivers, so if not, that's most likely your issue. At the very least, you will need the support page drivers or you can let Armoury Crate install most of them for you. 

The ethernet port should be on by default I believe. Not sure if there is a setting to turn it on/off without checking, but hope the above helps. 

Z690 Hero, BIOS 3101, MEI 2345.5.3.0, ME Firmware 16.1.30.2330, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Thanks, for your reply, John.

As far as I know, the drivers have to be installed AFTER the installation of the Operating System (Windows 11), if not installed automatically, when Windows installation is completed. For the time being, the problem presented at the very beginning, at one of the first steps, DURING the installation of Windows, and not AFTER it. This is why I am looking for a preliminary solution.

I know not with what weapons World War III will be fought, but World War IV will be fought with sticks and stones
Albert Einstein

Murph_9000
Level 14

The Windows installation media does not have a sufficiently up to date driver included with it for newer I225/226 Ethernet controllers.  This FAQ should help:

[Motherboard] Troubleshooting - How to install Windows 11 Pro/Home operate system on AM5 or Intel Z7...

Aaaah, thanks a lot!

It was really weird this behavior. Now, there comes the next question:

Should I re-istall the Windows from "0", or is there any method to load the driver at this stage, where the procedure has been stuck?

Not that I have a problem to re-install the Windows, it will only take me more time to do it.

Thank you, anyway.

I know not with what weapons World War III will be fought, but World War IV will be fought with sticks and stones
Albert Einstein

Finally, I considered it safer and not so much trouble to re-install Windows from "0".

It worked just fine. Thank you very-very much!

I know not with what weapons World War III will be fought, but World War IV will be fought with sticks and stones
Albert Einstein