cancel
Showing results for 
Search instead for 
Did you mean: 

1003 Bios update Z690

theroc44
Level 9
Just downloaded it. Looks like the microcode fixes for the AVX removal are there. I'm still trying to run 64gigs. Gonna see if this update helps at all.

29,249 Views
89 REPLIES 89

Just out of curiosity... did anyone have issues installing this bios?

The flash procedure finishes fine, but I still see the AVX-512 options and my ME version stays at 16.0.0.1423.
My board shipped with bios 0505 I think (something 05xx at least), so I tried to update one step at a time.
After flashing all the 4 available bios versions currently offered one after the other, I still don't see a change.
I'm only using the TUF Z690, if that matters.

Would the flashback option "force" the bios onto the board in some way? I think I've never had such an issue yet.

I'm going to wait for a couple more updates as I had issues with 0811 where the system refused to bootup and would freeze at the rog splash screen and pressing f2 or del would do nothing. If I kept rebooting the pc maybe 5% of the time It would let me in the bios so when I downgraded to the 0803 bios, no bootup issues at all. I made sure both bios's had the same settings too. This is with 2x16gb Gskill trident Z5 5600 ram.

drosso wrote:
Hi Sunfox,
I have the same exact RAM modules, but with 12600K and with a STRIX Z690 G-Gaming MOBO I had many issues on 0811 at XMP, with no XMP the system is instead perfectly stable; I've not yet upgraded to 1003.
Did you change any of the other settings in the BIOS to attain stability on 0811 or was it stable out-of-the-box ?
Thank you


Nope, it’s always been stable out of the box at XMP I. I can see no indication of actual different settings choosing XMP II on these sticks.

I’ve been really thrashing on the system this week, lots of video editing, rendering, terabytes of data copying from my old system, heavy multitasking… and Microsoft Flight Simulator on Ultra settings, and I haven’t had any crashes or other issues.

Installed 1003 on both systems today no issues. 1st I7 12700 with 32 GB Ram, 2nd I5 12600 with 16 GB. I'm not an overclocker. Both systems Ram is 2 sticks Viper Patriot Steel 3600 XMP 2.0 running in XMP1 profile on BIOS.

cristi80
Level 7
Any suggestion from anyone to my problem?

cristi80 wrote:
Any suggestion from anyone to my problem?


It's the chines new year.
So all we can do is sit tight and wait for the next bios update.

Afternoon all this might be worth a minute of your time incase you have similar specs and problems I encountered etc...

Like many I took the early adoption plunge and been very disappointed with this Generation of board, having upgraded from the previous gen board -- ASUS ROG STRIX Z590-F. Note: All NVME M.2/SSD/Gfx transposed over. (Note: New board manual says it supported 128gGB DDR5 up to 6400mhz Mem, small print check website for compatibility, disappointed big name like Corsair mem 5600 not on the Website list)

New system i9-12900K, ROG STRIX Z690-E Gaming WiFi, with Corsair Dominator Platinum RGB 5600 DDR5 32GB (2x16GB), New Corsair H150i Elite LCD. Transposed gear - Zotac Gaming RTX GeForce 3090 Trinity, 2x Samsun 980 Pro PCIE 4 M2 plus some older gen M.2 and SSD/HDD. Vanilla Win11 Build

New board came with 0709 BIOS and after putting all together like many initial booting didn't seem to go smoothly seeing multiple boot cycles before managing to start to load the OS. Defaulted Bios settings removing any usual tweaks I do. Managed to get stable boots to load OS (No memory XMP profiles loaded so sat at 4800Mhz). After several days fafing with poor loading times etc and getting random reboots and not able to get XMP running, I flashed to 0803, this mostly sorted my problems loading. Boot times were down to 22secs into Win11 no random resets and managed to get XMP 1 running memory at 5600mhz but was having other issues below:

Issue I had then was i was seeing poor gaming FPS in Warzone, at the plane screen before drop it would drop to 15FPS - WTF but this sometimes would clear after a reboot but then come back next time.
Some troubleshooting later looking at GPU-z I noticed that the PCIE speed before render test would be x1.1 then start render test it would go to x4 as expected but the Bus interface speed was always stuck at x1 4.0 and not the expected x8/x16 4.0 (Yes I know if the top M.2 interface is connected then the GPU would be set to x8).
After disconnecting all devices I found that when one of the SAMSUNG 980 Pro NVME drives occupied M2.1 then this was somehow causing the GFX to sometimes stick at x1 instead of x8/x16. Reconfigured system and moved drives off the first M.2 slot and everything was all stable, this makes the first slot a complete waste of space in my system. I was also getting my Deathadder Ellite randomly freeze for a min or more before sounding like it was being disconnected then reconnected. I have bought new VR VARJO Headset and the mouse freezing seems to be happening when this is connected, still trying to find solution to this USB shared resources issues etc.

So now I installed BIOS 1003 and although the info doesn't really give much info in the specifics on what its improved I was hoping newer memory modules were being tested and added to the list as well as other issues. I can say my system seems more stable, Boot times are good FPS in games (Warzone from the 15FPS above is now hitting 189-220 during the same sequence).

II have seen on these forums there's a newer Beta Bios and would be interested on what's been addressed and peoples thoughts

If this gives some hope to those also struggling then worth the 15 mins to input...

Jim

Hi all, Z690-G Gaming with Trident ZS@6000MHz here, XMP I never worked for me but XMP II is stable with BIOS 0811, after upgrading to 1003 every game would just freeze in less than a minute. Flashed back to 0811 and everything is fine again.
Dan

cristi80 wrote:
Any suggestion from anyone to my problem?

Did the BIOS (1003) and the flashback(s) complete successfully?
Have you tried re-seating your memory?

cristi80 wrote:
Any suggestion from anyone to my problem?


Is the flashback procedure completing properly? If the light flashes and then stays lit it’s not working. I had to use a different USB stick on my board.

Also try booting with just one stick of ram in A2.