cancel
Showing results for 
Search instead for 
Did you mean: 

Z590 maximus hero bios 1801

Marecki_
Level 8

Hello, after updating bios to 1801, rollback to  version earlier than 1701 is not possible. For me best version is 0902, motherboard post very quickly.

I'm furious is there a way to bypass this, modify a bios file or something else?

I tried ez flash and usb flashback.

sorry for my english

 

4,756 Views
35 REPLIES 35

Saltgrass
Level 13

That Bios was Jut released so I have not yet updated.  What type of problems are you having?

The inability to rollback is normally noted in the Bios update and seem to  be usually related to security updates which cannot be reversed.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

The inability to rollback is not noted in changelog. Problem is long bios post before windows  loading.

I just tried the update, after doing the ME Firmware Update. The  downloaded file appears to be the wrong size and the upgrade attempt stated the file was not a UEFI version.  

It is late here so I will wait until tomorrow and try again.  If yours installed, allI can suggest is to wait.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

Weird, I installed and downloaded twice. I can upload via usb flashback only one version back 1701.
You download the correct bios file I have z590 you z790.

I have a Z590 and 790 motherboard.  I redownloaded the file this morning and it installed normally.  

I do not seem to have any boot delays, but my Task Manager boot time is showing 13 seconds.  I have seen it faster but I normally don't worry about boot times unless it becomes excessive.  If yours is slow to boot, how do the small LEDs lights behave during boot.  Do they hang on one color or start over with the Red or Amber lights?

Currently running DDR 4 @4000GHz and XMP 1 settings.  My memory does say it is Intel XMP 2.0 capable so I will try that later.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

I did see an option to enable or disable a Rollback option.  I think it was in the Update tools.

I normally just copy the .CAP file to the root directory for updating firmware and use EZ Flash.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

I can't go back to a bios older than version 1701. can you try to flash, for example, 1601? Ez flash and usb flashback not work for me
I want to know if the problem is only with my motherboard

Enable Fastboot. If POST times are longer the board might be attempting retraining if XMP is applied.

Regarding rollback, will need to confirm. The ME Firmware is normally the reason why this is the case.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

I've always had asus motherboards and this is the first time I've encountered a usb flashback lock. I've never had any problems with flashing older bios versions. Ez flash I understand it but by flashback it should always work I guess