Showing results for 
Search instead for 
Did you mean: 

Z590-F Sound Issues - Optical Cable

Level 8

Recently purchased a ROG Strix Z590-F motherboard but I am having issues with the sound. I have my amp connected to the computer via an optical cable. Randomly however the sound will switch to a hissing crackling sound and the only way I can get it to work again is by disabling the "Realtek Digital Output" and re-enabling it only for the same issue to happen again. The cable is fine as it worked fine in another computer attached to the same amp. This happens with all sound sources as far as I can tell, so games you tube etc... My sound drivers are up to date as far as I can tell. This has become extremely annoying.



imacken wrote:
I have the exact same issue, i.e. sound just turns into static after a few minutes - usually 10-15 - in games.

I have a Z590-F which I initially used with my Sound Blaster Z with no issues. I then decided to give the onboard Realtek audio a try to save a PCI slot.

I am connected to my receiver by the optical cable on the ASUS onboard panel, and was using the 2276 drivers, and then the 2277 ones from MoKiChU. Issue was the same. Cable and receiver both are working perfectly.

So, I uninstalled all the Realtek drivers and components, as well as removing drivers via DriverStoreExplorer and started using the SPDIF Interface (Realtek USB2.0 Audio) option without installing any drivers to see if that makes a difference. It didn't.

If anyone can offer help here, it would be appreciated as at the moment, I just can't use this ASUS onboard device.


If your issue persists with Microsoft built-in audio drivers, please open a ticket at ASUS Support.

Will do, but this is kind of ironic given that I bought the Z590 board after my Z490 had a faulty MEI!

Level 11
I can bet it is not a problem with the drivers, or not only with the drivers, but with the power management options in BIOS as well. As I said, had the same issues with the Z590 Hero.

Can you expand on that? What power management options?
Thanks. Â*

Level 11
CeC 2019, ErP Ready, plus the PCI-e power management stuff, like ASPM. I indicated that above.
Settings as pictured give me no issues, BUT set the ErP and CEC BEFORE setting the other ones, as ErP and CEC change those other settings as well as AURA settings and C-States settings.

OK, I'll give that a try.

Just an update on what I think was said above somewhere, after a lot of testing yesterday, I can confirm that it is only the optical output that has this issue. Using direct input via jack/phono leads, the problem does not occur.

Can I ask, having tested a lot yesterday, I can't get the Realtek sound quality to be anything like as good as my Sound Blaster Z. Is that what I should expect, or with some more tweaking, could I get it on a par?

I tried all the below and once again it worked for a while, but then the same issue appeared. I have switched to an RCA to stereo jack cable and dont have any issues. Hopefully they update the drivers soon to ones that work. I also wouldn't think you should need to go into the BIOS and start changing power management settings to get your sound to work.....

"- Follow scrupulously your CLEANUP process
- Use this SS3 Cleaner tool (Right click on "A-Volute_SS3_Cleanup.exe" > Run as administrator) then restart your PC
- Follow scrupulously your INSTALL process

For the next drivers packages that I would release, you will can directly follow your UPDATE process.

If your DPC latency issue persists, in order to try to fix it, follow this process (also visible in TIPS at the bottom of all my audio drivers threads) :

1) Disable hibernation :

- Right-click Windows Start button then click Search.
- Search for cmd. In the search results list, right-click Command Prompt and then click Run as administrator.
- If/When you are prompted by User Account Control, click Continue.
- At the command prompt, type powercfg.exe /hibernate off and then press Enter then close the Command Prompt

2) Enable MSI (Message Signaled-based Interrupts) mode on all your supported devices (see the column "supported modes") with MSI Mode Utility (Right click on "MSI_util_v3.exe" > Run as administrator), then Apply, then close MSI Mode Utility & restart your PC"

I heard from ASUS on this. A total joke. Pointed me to a link showing how to get audio working when you hear no sound!

imacken wrote:
I heard from ASUS on this. A total joke. Pointed me to a link showing how to get audio working when you hear no sound!

yeah that's always first tier support. You basically have to tell them that you have tried all of the above and that your not in diapers anymore . :cool:

So, after an exchange of 'update your drivers' (seems to be tech support's answer to everything!) ASUS have told me to RMA the board.

I have just replaced my Z490 board with this one as I had to RMA it because of faulty MEI chip, so there is no way I am going to go through all that again.

It's back to my Sound Blaster Z where I have better quality sound and DD.

Oh well, so much for trying to save on a PCIe slot!