Showing results for 
Search instead for 
Did you mean: 

z490e ethernet issues/ new ethernet question

Level 7
Hey all,

Been dealing with this junk ethernet on 2 computers, Its been working Ok until i started doing backups using synology.
Long story short the built in Intel(R) Ethernet Controller (2) I225-V. its fully updated with the firmware as well.

Symptoms: when a backup is initiated the ethernet becomes unresponsive, cannot disable from device manager, cannot reboot pc unless i flip the power switch.

I worked with synology support extensively running through logs, fixes, adjustments and the conclusion was that it only happens on this ethernet on 2 separate computers. Wifi works fine

I installed a tplink TG-3468 and I no longer have issues However why is it showing as realtek pcie gbe family controller instead of the TP link device? Not sure if its a huge deal.
Tried to contact support but apparently if you choose US the technical support function disappears (real nice asus)

Level 7
ended up installing the latest windows drivers from

updated everything to 2022 drivers