cancel
Showing results for 
Search instead for 
Did you mean: 

z490/z590 bios will not flash, possible solution

bscool
Level 11
Since Rocket Lake release I have seen quite a few people post about the board acting like it is dead or one of the bios will not flash on a dual bios MB like Apex.
I ran into the same issue with z490 Unify and 11900k where the MB would not do anything.

Someone on a German site just posted about this with z590 Hero and 11900k and they could not get the MB to post or flash the bios via flashback. I suggest removing everything(so just MB and PSU) and then try flashback and it worked for him so posting it here. Try it as a last chance if nothing else works.

Disconnect everything, Sata, NVME, RAM, CPU etc. and then try flashback

https://www.youtube.com/watch?v=28okjfzHMMA
1,189 Views
3 REPLIES 3

Saltgrass
Level 13
I suppose a question I might ask is why go through all that trouble when you can just do it from the Bios using EZ Flash. I can see the attraction if the Bios Flashback worked but unplugging everything is a little more than should be required.

I will try it the next time I do a Bios update..
Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

bscool
Level 11
The reason to do this is you cannot even boot the MB so how could you do EZ flash?

It is a last resort and no reason to do unless nothing else works. I said in the first post the board acts like it is dead or the board does nothing.

Also it may not work and the bios is still bricked.

MrAgapiGC
Level 13
i check a guy locally with the same issue. using a z590-e with a 10700k once he update the bios, did the flashback, turn on the pc, load the lights update and then ... that is it. I will meet the guy today to check that out
Learn, Play Enjoy! We help and collaborate, NOT complain!