Showing results for 
Search instead for 
Did you mean: 

Strix Z490-E / CPU 10700K / BIOS 2103 / GPU and Ethernet problems

Level 7
Mobo: Strix Z490-E
CPU: 10700K
BIOS: 2103

Hi folks!

Hoping I can get some advice on the following issues please. I updated bios to support nvidia resizable bar.

1. GPU problem:
My 3090 FE works absolutely fine when I have it connected THROUGH a gen3 riser cable. But when I connect the gpu DIRECTLY into the mobo, it doesn't power up at all. I've tried setting pcie to gen3 in bios, disabled resizable bar and clearing cmos, but no luck. Still works absolutely fine with riser cable.

I suspect that when connecting the gpu directly, the mobo is trying to force gen4 on it (because both mobo and gpu support gen4). But the gpu doesn't power up because the cpu don't support gen4. Since the riser cable is gen3, mobo then sees the gpu as gen3 and powers it fine.

2. Ethernet problem:
When cold booting, I never get a successful ethernet connection. It just doesn't pick up. I have to reboot and then it works. I had this problem when I updated to bios 2103 AND updated Intel I225 LAN driver to v1.2.0.8. I'm not sure which of the two is the culprit.

3. What is the best bios version for this mobo and cpu? Are the 2xxx bios' for 11700k specifically which is why I'm having the gpu issue? Should I downgrade my bios to 1003 or update to 2301?


Level 7

What about best bios for 10700k and Strix Z490-E board?

Level 7
Aight, i'll try to help you out since my setup is pretty similar, 10700k, Z490-e (bios v2201), MSI gaming x 3080

1. I don't think gpu issue is Gen4 issue because you would need a 11th gen CPU for that to actually work, 10700k only does pcie gen3, still doesn't explain your "works with riser" scenario, have you tried a different x16 PCIe slot? topmost preferable.

2. Don't think i've had any big ethernet issues, altho i force the connection to 1gig full duplex in the driver and turn off the power saving options (energy efficient ethernet + power managment tab all off), device manager shows driver version is Did you do the NIC FW update to 1.45?

3. I've found that 2201 is fine for what i do, no huge overclocks just bumped AI OC to 4.8ghz and mesh?Uncore?ring? to max 4.5ghz

BloodBaron wrote:
Aight, i'll try to help you out since my setup is pretty similar, 10700k, Z490-e (bios v2201)

Thanks for your input. Good to know the newer bios is working fine for you. I shall try a newer bios and see if that resolves my issues.

Level 7