Showing results for 
Search instead for 
Did you mean: 

ROG Z590f 2nd M2 SSD keeps disconnect in random usage scenarios

Level 8
Hello as i mentioned in the topic too , only my 2nd m2 nvme ssd is disconnecting and i cannot reconnect it until i shutdown the pc ,if i restart PC it still not connecting, only reconnecting when i shutdown pc( i do not unplugthe power or discharge the pc, just shutdown and starting again)

in my previous MoBo i dont have any trouble like this, i had z"490 msi" mobo, it is bricked while updating bios so i 've changed my mobo to "ROG Strix Z590-F Gaming Wifi"

by the way my pc spcec.s are here (and Thermaltake750W Bronze PSU)

i have 4 storage drives and 1 optical DVD drive

1x 256 GB SSD sata6 (where windows is installed)

1x 1 TB HDD sata6 (back up)

2x m2 NVMe SSD (intel 660p 1 tb and 512 gb a chinese brand ssd)(both m2s are PCIe 3.0 x4)

optical drive, HDD and SSD are connected sequentially sata6g 3-2-1 ports

intel ssd is connected m2-2 slot (m2-2 slot is direclty connected to cpu)

chinese brand ssd is connected m2-3 slot (m2-3 slot is connected with z590 chipset)

Only Chinese brand m2 is disconeecting and i dont have any trouble with other drives.


1-) what's happening, when/while m2 ssd disconnecting?

Program/game/application is start freezing, i cannot open any folder, when i start task manager it start as empty window. i can click everything but nothings are responding my clicks. After wating 1-1.30 mins, all objects that i clicked while pc freezed opening/starting together.

and this is the video what's happening to "m2 ssd leds" while m2 disconnecting pc and bios

here (start at 21st seconds)

M2 led is lighting solid green and even i restart pc led is continue to lighting solid green . Only When i shutdown pc, the led turn off and reconnecting.


2-) When does my M2 ssd disconnect

whlie playing game (most of my games are installed intel ssd), it disconnets in the mid of the.

whlie playing game which is installed chinese brand ssd. (immediatly disconnecting when the game starting or loading games or loading game files at start or benchmark or browsing in game menu)

while playing videos/movies (The videos are not in the m2ssds

wihile gpu is in load (in full load or half load, doenst matter in gpu starting in load m2 disconnecting immediatly or 30 mins or 1hours later or 2 hours later.


3-) When does my M2 ssd not disconnect

in stress tests

full stres test gpu, cpu,ram,dirves

while browsing in the web

while using program/application which is installed chinese brand ssd.

while using program/application which is installed other drives.

crystaldisk mark test

here are pics are results crystalmark/info


4-) what i tried

enabled/disabled XMP

enabled/disabled ReSizeBar

Connect/Disconnect some Sata Dirves sockets

all combination of m2 ssd slots, i tried all m2 slots and z590/CPU Pcie line combination

Pluged/unplugged all MoBo sockets

Pluged/unplugged Rams

Pluged/unplugged 8+4 CPU power socket (unplagged 4pin cpu power socket)

plugged additional 8 pin socket to Gpu (Previously was using single cable for GPU(8+8) now i am using 2x8 pin socket for GPU)

And these are voltage status while in load and iddle

The voltage result while in full strest test( gpu, cpu,ram,dirves)

in load


watts in load

Level 12
to much data. please open diskpart in admin and see if on legacy or MBR. if so, remove it data and on bios secure erase and in windows remake on GTP and add you files back.
Learn, Play Enjoy!

MrAgapiGC wrote:
to much data. please open diskpart in admin and see if on legacy or MBR. if so, remove it data and on bios secure erase and in windows remake on GTP and add you files back.

Both m2 ssd are already parted as GPT

still need help

Level 9

I have the same problem with Samsung 980 2TB SSD mounted on 2nd-slot SSD of Zep M16 GU603ZW laptop, in use it also freezes everything, I checked the SSD in 2nd slot is missing in Task Manager and everything is almost useless (because the program and the game I save to the drive in the 2nd Slot) - I reported it to the ASUS service center, and they reported that the error could not be tested, it also appeared Incidentally, I just want to sell the machine now. Before that, I also thought it was an SSD error, I was also replaced by a new BH before, I consulted google information, many other SSD brands were also... too boring.

Processor: Core I9-13980HX
Motherboard: ROG Strix Scar16 (G634JZ-N4029W)
Graphics Card: GeForce RTX 4080 Laptop GPU
Storage: MZVL2256HCHQ-00B00 (GXA7601Q) + MZVL22T0HBLB-00B00 (GXB7601Q)
G502X Plus (910-006164)