cancel
Showing results for 
Search instead for 
Did you mean: 

ROG B560 A Gaming not powering USB flash drives

carush2506
Level 7

So I recently upgraded my setup to include a 4070 Super and of course to go along with that I upgraded my PSU to a 750w supply. Problems started when I first tested the GPU, as the USB ports stopped powering USB drives. If I connected a keyboard or mouse they still worked, but USB flash drives would not power on.

After mounting the new GPU and PSU, now none of the USB ports will power up USB drives. I have tested USB 2.0 and 3.0 flash drives, an external HDD, and a wired xbox one gamepad and none of them power on when connected to any of the USB ports, including the one from the frontal panel. What is strange is before the swap, the USB ports were not booting flash drives but they did boot my external HDD. Now not even the external HDD powers on. When I connect the HDD it spins for a moment and the LED on it blinks but then it immediately shut off.

Other peripherals such as keyboard, mouse, headset and webcam work correctly. It just appears like specific devices are not getting powered by the motherboard. I've already tried to clear the CMOS and reset BIOS to default settings, enabling/disabling UEFI/Legacy for USB, reseated CPU and replugged all cables and nothing. It appears the motherboard flat out refuses to power any USB drive. My last option is to do a BIOS update but I have no idea how to accomplish that because the BIOS will not even read any USB drives plugged in before booting Windows. I have a pendrive with Windows 10 on it and BIOS refuses to read it, again it does not even power on.

I am at a total loss here and I'm afraid my mb might now be bricked in some way. Here are my specs:

ASUS ROG B560-A Gaming WiFi
Intel Core i5 11400 @2.60 GHz
MSI Ventus RTX 4070 Super 12GB
2x8GB Patriot Viper 3200 MHz CL 30
1x SSD Western Digital WD Black SN770 NVME M.2 1TB
1x SSD ADATA SU650 SATA 480GB
1x SSD Western Digital WD Green SN350 NVME M.2 1TB
PSU is a Corsair RM750e 750W Gold Plus

Any help would be immensely appreciated!

73 Views
0 REPLIES 0