Showing results for 
Search instead for 
Did you mean: 

Maximus XIII Hero & Thunderbolt Drive using OWC Envoy Express - Only works when connected pre-boot

Level 7

I have the Maximus XIII Hero, BIOS 1602 (Nov 2022) and Windows 10 Pro.  

Last year I purchased an OWC Envoy Express drive container. It's TB3.  The SSD contained in it is a new Samsun Pro 970 1TB Drive.  Works perfectly on my Macbook Air.  On my ASUS it only works when connected during Windows bootup.  If I chose to remove it safely within windows, I can do that However if I reconnect the drive WIndows will not recognize it.  The TBT Controller sees when I connect it.  No Authorization issues.  I have worked with OWC on this problem for two weeks and tried working with ASUS Technical Support but this has been futile.  They say they will have Tier 2 reach out, but nothing.  

I worked with OWC on the BIOS settings when I initially purchased the device to just get it working, enabling TBT.  I don't honestly recall if this issue existed then or not; I believe it did and I didn't worry about it. 

I have updated drivers, have the latest TBT driver from the website. 

So the drive has a NVMe drive which I believe is really a PCI Express level connection (? Could be wrong). Also, I have an OWC TBT 4 HUB - same results through the hub or not.  Interestingly I have a couple of Samsung T7 drives (USB) and when they connect to the hub, they work fine, including easily reconnecting them and windows recognizes them instantly.  But this drive enclosure (OWC Envoy Express) does require TBT3, which certainly I have). 

I'm running out of options. I have tried a few odd things with the BIOS related to Thunderbolt and PCI Express.  I have even reviewed the SSD / NVMe drive using Samsun Magician and I have the latest Firmware on the SSD - and it appears to be working fine.  Again, when I boot with it - it works fine too.  But removing it is the end of it during that windows session. 


Do I have an expectation that ASUS cannot meet?  OWC and others seem to think "this is the TBT standard and it should behave accordingly. A friend with a Dell windows laptop - works fine. 

I have not tried WIndows 11, but not sure I should need to.  ???