Showing results for 
Search instead for 
Did you mean: 

Maximus XII Extreme ethernet adapters download limited to 95 Mbps

Level 7

Sorry if this is a repeat question but I can't figure out how to search the forum.

I have a ROG Maximus XII Extreme motherboard with 64GB memory and a lot of bells and whistles. It comes with an Intel I225v 2.5Gbps NIC and a Marvel 10Gbps NIC. I have an Intel Core i9 10900K that's not overclocked.

I can't get over 95 Mbps (WAN and LAN) out of either adapter.

I have tried my 6-year old ROG G751 gaming laptop on it and the download speeds are consistently in the 170Mbps range (about what I'd expect for that laptop).

I have tried my relatively new Dell XPS-7390 with a USB-C to Ethernet adapter (and use the same CAT 5e cable as on my Maximus XII Extreme) and achieved 470Mbps download speed.

My WiFi 6 card on my Maximus XII Extreme gets 470Mbps download speed, too (on WiFi).

Here's what I've done:
1) Unplugged and replugged cable from switch to the wall outlet,
2) Punched down the cables on the wall outlet connector,
3) Tested continuity on all 4 pairs (all good - good enough to get 470Mbps on the Dell),
4) Updated the controllers for both NICs,
5) Updated the drivers for both NICs,
6) Disabled and re-enabled the drivers for both NICs,
7) Uninstalled the drivers for both NICs,
😎 Reinstalled the drivers for both NICs,
9) Restarted the computer with each change

FWIW - I have two M.2 cards in play and that takes out one of the PCI lanes (I think but not 100% certain)

The NICs act like they're throttled because the speed test ( is consistent every test - 95Mbps down/ 12Mbps up.

I couldn't find anything in the manual or in the BIOS settings (it'd have to be real obvious in the BIOS settings because I'm not a BIOS guy - so I might have missed something).

It's probably something obvious and simple that I'm missing, but I'd greatly appreciate any help! (It just doesn't seem right that a 6-year old laptop would have a higher download speed than this fancy motherboard. And it's really sad to have a little bitty Dell laptop that's a year older than my motherboard gets 5 times the download speed from the same cables.)

ROG Maximus XII Extreme
Intel Core i9 10900K 3.7 GHz (Turbo to 5.2 GHz)
64 GB G.Skill
EVGA GeForce GTX 980Ti
Kracken X73 Closed Loop Cooling System
Samsung 980 PRO 2 TB NVME M.2 SSD

I'd also check to see if you have the newest chipset driver. Beyond that I'm not sure if there are any related BIOS settings. I doubt there would be anything that would force it to operate at such a slow speed so it sounds like a bug or hardware issue more than a setting.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

I just boght recently an Asus ROG Strix Z590 and I just noticed that it drops ethernet while my sons are playing Minecraft.

Every time they are playing Minecraft, the network conection just drop.

And another interesting thing, is that when it happens, the computer don't finish the Windows 10 turn off proceadure, or even restart proceadure. It initiate the process, but when the screens go black, it just freeze. Power button don't work, reset button don't work also. Just hard reset.

Researching my problem, find out lot's of people with bouth problem... with other MB brands, or MB Asus models! For me, it's an Intel I225V problem.

Try here...

Already try everything, no success yet. About to return my board and trying another brand that uses another ethernet controller, cause all the best Asus MB are using Intel I225V controller.

Best of luck,