Showing results for 
Search instead for 
Did you mean: 

Bios 2801 + Intel ME driver = bricked PC

Level 9



my PC was running fine with the latest bios installed (2801)

I then noticed on the bios download screen information about downloading the latest Intel ME driver.

i downloaded the latest ME driver, it installed ok then asked to restart.


i clicked restart and the PC won’t boot.

it starts for 3-5seconds, clicks off, then repeats.

please advise…..




Hello GibsonRed

Try reflashing the bios with the bios flashback feature if your motherboard supports this.





Thanks for the reply.

should I re flash the latest bios or an older one? 


I'd try reflashing the latest bios (2801) and see how it goes.






Hi, tried re flashing bios 2801 and 2601, same boot loop issue, turns on for 8 seconds then clicks off and keeps looping.

Ive got it to boot with 2201.

how do I update the bios now? Can I roll back the intel ME driver by installing an older one on off the ASUS website?


I’ve tried loads of bios files and nothing past 2201 works….

2801 was working fine until I updated the intel ME driver….

This has been a problem before it appears…

No matter which intel ME driver I download from ASUS’s site it doesn’t roll back.

in the bios it always says version

How do I roll back the intel ME firmware??? So I can get the latest bios to work again?

all I did was follow ASUS’s instructions on their website?!?!

this bios isn’t even compatible with windows 11 (which I’m running) so it’s throwing up warnings about TPM with this bios that weren’t there before…..

my motherboard is revision 13 not 14….don't know if that has anything to do with it……


I need to be able to roll back the Intel ME driver as any bios after 2201 doesn’t seem to support it……….

how do I roll it back????


I'm so disappointed in ASUS, I’ve always bought ASUS boards and it looks like they don’t even test them anymore…..

everyone is going to have this problem…..I’d get it fixed quick……

how do I roll back intel ME firmware????


If you're able to boot to windows with bios version 2201, try uninstalling the Intel ME driver from device manager.

Once the Intel ME driver is uninstalled, try updating the bios again. Check the bios release notes, updating the bios may update the Intel ME driver as well.

Uninstall Intel Me.png



Thanks for the reply nate. I tried to reinstall the driver a few times but it’s the actual bios firmware that been updated.

I didn’t try to uninstall the driver though.

the ME firmware version on the home screen of the bios won’t change no matter what I do.


apparently you can roll back the Intel ME firmware but you need a special file from the motherboard manufacturer.

i.e I need a bios or ME version that will allow me to roll it back.

i think there’s a difference between the Intel ME driver and the Intel ME firmware.

otherwise it would only be an issue when getting into windows and wouldn’t stop the pc from booting within 5 seconds.


theres something in bios 2201 that allows it to boot with the latest Intel ME firmware (latest on the ASUS site) that isn’t in all the bios versions after 2201……

your engineers need to retest this on a rev 13 board with a 10th gen cpu……..


with this bios I bet I can’t even reinstall windows 11 again if I wanted to.

I linked to the other thread where people have had this same problem…..

what’s going on with ASUS? Don’t they test this out? How can this issue still be ongoing???


how do I roll back the Intel ME firmware? There must be a bios or ME firmware update ASUS can release that will fix these issues loads of people are having?


The firmware physically updates the CPU. This is where the problem actually arose for me because I already had BIOS 2801 and the ME driver installed. Once I ran the MEUpdate tool, my system became stuck. They made it so you can't revert back using the older firmware tool. The system will simply state that the firmware doesn't need updating.

Level 7


issue was with my cmos battery.