cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Maximus XIII Hero, is there a new bios version arriving ?

74lobster
Level 10
Hi, just a question: for Asus Rog Maximus XIII Hero, there is a new bios verion incoming ?

I have the last version 1402 installed, but it has issues with the last Windows 11 updates and moreover with the update Windows 11 22h2...

Thanks for the attention.
74lobster
4,217 Views
23 REPLIES 23

sdmf74
Level 11
I have been having issues with bios 1402 for a LONG time, I sure as hell hope Asus didn't simply release the same bios w/ a new version number (1601) only for a microcode or ME update.

I'm guessing since all we got is "improved system stability & compatability" for a changelog nothing that needed fixed was, but hey I get to manually re-enter ALL my bios OC profiles (sarcasm)

If you changed nothing just simply say "we borked your performance to patch a vulnerability & changed the bios version number just to screw w/ ya".

Maybe @Merlin should start fixing Asus' motherboard bios' also! At least he offers a detailed changelog file with EVERY router firmware update.

Please if anybody finds any links and/or notices any changes (good or bad) with Z590 Hero bios 1601 let us know??? Thanks!

(Oh and is this the same bios 1601 that the Z690 Hero had like 5 versions ago? Or just couldn't randomize a different 4 digit version number?)
ASUS Maximus 13 Hero, Intel I9 11900k, EVGA GeForce RTX 3080 FTW3 ULTRA

SinisterDev85
Level 11
So far so good for me on the 1601 bios for the Maximus XIII Apex. System has been really stable in stress testing and benchmarking. Even got my 5.6ghz OC profile working almost effortlessly. Nothing bad to report atm.
ASUS ROG Z790 Apex Encore | i9 14900ks | | G. Skill Trident Z5 8000 | 2x WD SN850x 4gb | Asus Strix RTX 4080 OC| Asus ROG Thor 1200w | Windows 11 Pro

SinisterDev85 wrote:
So far so good for me on the 1601 bios for the Maximus XIII Apex. System has been really stable in stress testing and benchmarking. Even got my 5.6ghz OC profile working almost effortlessly. Nothing bad to report atm.


You are lucky, both 1402 and 1601 are broken on my M13A with a 10900k. both of those version will boot up the first time after flashing and then any successive boots just sit at the post splash screen and never boot into the OS or allow me to boot into the bios. rollback to 1301 and everything is fine, upgrade to either 1402/1601 and the systems just sits at the rog screen....

Watchmydebt wrote:
You are lucky, both 1402 and 1601 are broken on my M13A with a 10900k. both of those version will boot up the first time after flashing and then any successive boots just sit at the post splash screen and never boot into the OS or allow me to boot into the bios. rollback to 1301 and everything is fine, upgrade to either 1402/1601 and the systems just sits at the rog screen....


I just opened a topic for this one, did you tried to reset your bios to factory settings and on the next boot just let your pc sit on the ROG screen for a few minutes. Eventually it will come through and on your next restart it will fly through it.
But when you do a hard shutdown and wait 15 mins or so, it will be sitting again on the ROG screen etc etc....
it's an issue that I saw on all bios updates besides the 1301.