cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Maximus XIII Hero, is there a new bios version arriving ?

74lobster
Level 10
Hi, just a question: for Asus Rog Maximus XIII Hero, there is a new bios verion incoming ?

I have the last version 1402 installed, but it has issues with the last Windows 11 updates and moreover with the update Windows 11 22h2...

Thanks for the attention.
74lobster
847 Views
23 REPLIES 23

PerpetualCycle
Level 13
I have the same question Asus is still selling the board after all.

There are bugs in the firmware that I wish would be fixed. There is also newer microcode that addresses some security vulnerabilities ( 0xEE).

Also, Asus are behind on the Intel Management Engine firmware. There is already at least 2 Management Engine vulnerabilities that are fixed with a later version of the ME firmware than what is available on the Asus site.

ROG Hero XIII | 10900k @5.2 GHz | g.skill 2x32GB 4200 CL18 | ROG Strix 2070S | EK Nucleus 360 Dark | 6TB SSD/nvme, 16TB external HDD | 2x 1440p | Vanatoo speakers with Klipsch sub | Fractal Meshify 2 case

Saltgrass
Level 13
74lobster wrote:
Hi, just a question: for Asus Rog Maximus XIII Hero, there is a new bios verion incoming ?

I have the last version 1402 installed, but it has issues with the last Windows 11 updates and moreover with the update Windows 11 22h2...

Thanks for the attention.


What problems are you having? My system picked up 22H2 the first day it came out.

But as you mention, you already have the latest Bios I know about.
Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

ThomasRhin
Level 7
booting is slow,incompatibility of detecting ASUS sound card(eg. Strix DLX series), poor memory overclocking capability,especially Micron chips. All of these are just ignored by ASUS. Many of other brands are still offering new BIOS to correct issues. You guys can check Station-Drivers web site frequently and you can see other brands make more efforts to complete 11th gen motherbords in BIOS quality than ASUS does. ASUS also ignore their sound card for driver issues. I hate that i have bought all these products which become orphans already !

ThomasRhin wrote:
booting is slow,incompatibility of detecting ASUS sound card(eg. Strix DLX series), poor memory overclocking capability,especially Micron chips. All of these are just ignored by ASUS. Many of other brands are still offering new BIOS to correct issues. You guys can check Station-Drivers web site frequently and you can see other brands make more efforts to complete 11th gen motherbords in BIOS quality than ASUS does. ASUS also ignore their sound card for driver issues. I hate that i have bought all these products which become orphans already !


The latest BIOS update for Z490 is newer than the one for Z590.

There are bugs that need fixed. For instance the automatic voltage limits do not work (at least for 10th gen processor on the board), turning off Overclocking TVB actually enables it instead and disabling them core by core is convoluted and a chore, There are UI bugs, like when loading from a saved profile, and others I don't recall at the moment. The microcode is outdated as well as the Intel RST EFI driver and other EFI drivers.

As for the ME firmware, there are at least two newer security vulnerabilities that are not patched on the version provided on the ASUS website.

ROG Hero XIII | 10900k @5.2 GHz | g.skill 2x32GB 4200 CL18 | ROG Strix 2070S | EK Nucleus 360 Dark | 6TB SSD/nvme, 16TB external HDD | 2x 1440p | Vanatoo speakers with Klipsch sub | Fractal Meshify 2 case

DarvinAtkeson
Level 7
There seems to be a real bug in the 1402 firmware. Specific to connecting external USB hard drives.

If a USB drive is connected, the system will become very slow to post.
Connect 2 or more and the problem gets really bad.
I have seen POST times of up to over 4 minutes. With most boots taking closer to 2 minutes.

I think it may also be related that using an NVIDIA card can have boot up with no display. That is to say it boots into Windows with no display at all. You are in Windows but the screen never even turns on.

I am currently trying to get to talk to someone who works with the BIOS updates to get this addressed.
I know it is BIOS because it happened on my Maximus XIII Hero. They wanted to RMA it and I can't be without a system so I purchased a Z590-E Gaming System and after getting it built, same exact problem.

No USB drives is a lightning fast 14 seconds to see the Windows start loading.
Add one USB 30 seconss. Two 45 seconds. Three starts getting close to 1 minute just to post.

If you have a USB drive, disconnect it and see if you notice a time in how long before you see the Post screen. My guess is it will speed up if you remove your USB drive.
Unfortunately I do photography and video and have 6 Segate USB drives so I can turn the system on and go do something while my system boots.

But they keep wanting me to RMA both boards saying the board is broken.
This has been plaguing me for over a year now.

Darv

Another component missing updates would be the I225 NIC.

Intel describes the current firmware as "quite old":

However, NVM 1.57 is quite an old version, and getting a new I225 NVM might help with the problem. Unfortunately, Intel cannot release the NVM update tool to end-users because it must come from the manufacturer after they finish validation and integration.


https://community.intel.com/t5/Ethernet-Products/I225V-connected-to-NetGear-XS724EM-losing-connectio...

PerpetualCycle
Level 13
The neglected stopgap series :mad:

ROG Hero XIII | 10900k @5.2 GHz | g.skill 2x32GB 4200 CL18 | ROG Strix 2070S | EK Nucleus 360 Dark | 6TB SSD/nvme, 16TB external HDD | 2x 1440p | Vanatoo speakers with Klipsch sub | Fractal Meshify 2 case

There is an ME update available (Version 15.0.42.2235 2022/11/18).

Maybe a new BIOS will follow ?

Districtor.2 wrote:
There is an ME update available (Version 15.0.42.2235 2022/11/18).

Maybe a new BIOS will follow ?


They can bundle an ME firmware update with a BIOS update, so I think it is unlikely. Can only hope though.

ROG Hero XIII | 10900k @5.2 GHz | g.skill 2x32GB 4200 CL18 | ROG Strix 2070S | EK Nucleus 360 Dark | 6TB SSD/nvme, 16TB external HDD | 2x 1440p | Vanatoo speakers with Klipsch sub | Fractal Meshify 2 case