Showing results for 
Search instead for 
Did you mean: 

ASUS PRIME Z590-P PCIe Wifi cards not working

Level 7

Back in January I purchased an ASUS PRIME Z590-P mainboard to build a new Windows 11 system for my wife. We have a wired network, so I did not buy the Wifi version. Now we've moved the computer and cannot make a wired connection so I want to install a Wifi adapter that will take advantage of our Wifi 6 system.

Right now my wife is using a small USB 802.11n wifi adapter and it seems to be working OK.

I've tried two different PCIe adapters, a Gigabyte GC-WBAX1200 and an Asus PCE-AC55BT. Both of these PCIe cards come with Bluetooth, which connects to a USB header on the mainboard. The Bluetooth on each of these cards works fine, but the Wifi portion does not. The Asus card was never detected by the PC - Nothing showed up in the device manager when it was installed. When I first installed the Gigabyte card it worked well... until I powered off the computer. From that point on the card was not detected at all by the PC, again nothing in device manager.

It seems odd that I couldn't get two different cards to even show up in device manager. I would like to know if there is something about this mainboard that could have issues with these cards, be it a BIOS setting, or some quirk of the PCIe implementation, etc.

Should I try another PCIe card, or should I get a USB 3 Wifi 6E adapter?


Level 12

With these motherboards, you have to be very aware of what plugging in a PCIe card, would to do on that system.  If there was some type of conflict, it may be causing your problems.  I will assume, you have the external antenna connected.

I have used a card such as you mention, but not that exact card, and it worked fine on a similar system.  They also make external USB dongles for Wi-Fi + Bluetooth.

Maximus Z790 Hero,
Intel i9-13900k
Intel AX411


Hello Calab

Knowing what all is connected to the motherboard can be a big help. While they initially worked, it's possible you've used all the pcie lanes and could be why they're giving you trouble and not detected.

It might be better to stick with the usb adapter since it's working well for you.