cancel
Showing results for 
Search instead for 
Did you mean: 

Apex XIII Power Button Blink every 2 secs

ProStock
Level 7
Hello Well just got my new Z590 Apex and i test the mobo on a bench before install it in the case
So after i install ...

Cpu: 11900K Ram: DDR4 3600QVL Gpu: Rx6900Xt Nvme: Rocket + 2tb Psu: "Corsair RM850x Boths 12V 8 pins connected"

i push the power button and notin happen no power beside the power button &the bios led is blinking each every 2 seconds
so i shut down the psu and remove cpu & ram & gpu & nvme i inspect the with macro the lga socket to see if there is bend pins all good
then i check macro the pci-e 16x slot same thing all good & check also ram slot all good as well for the nvme on the top of the pcie 16x

then i put back my hardwares cpu & ram & gpu & nvme on my previous motherboard msi Z590 carbon and everything fire up booting in windows

so far i found on asus FAQ: slow power button blinking every 2 seconds means "VGA ERROR DETECTED"
i test the Apex without any hardware installed and when i push the power button same thing blink every 2 secs
i Try to switch Bios from B1 to B2 notin is stay on B1 i try to force the Bios using a jumper to use B2 same stays on B1
i Remove the Cmos batt for 2 hrs and remove the psu power and unplug it from the wall same result still blinking
i dwl the last bios from asus ROG-MAXIMUS-XIII-APEX-ASUS-1007 put it on usb flash and plug into bios flashback same result when i hold the Flashback Button it doesn't start to blink like its reading the bios on the usb
i have another Gpu 1080ti but i guess it wont change anything putting this card in the pcie 16 slot

So im kinda bummed and out of solutions maybe you guys can tell me if it's possible to use the second pcie16x and boot from it ?
but this also looks like it wont do anything cause it blinking without hardware's

any helping hands will be appreciated thx
540 Views
1 REPLY 1

kvarq
Level 11
welcome to the club :))
Apex XIII is a pretty crappy board, should have read a line or two before buying it...
I gave up on mine after three months

try 0903, might be a bit more stable with that one
https://rog.asus.com/forum/showthread.php?124211-Z590-Apex-motherboard-goes-on-and-off/page3#post835...

bios is a mess, but on the other hand the board has its flaws as well...
try also connect to the power supply the D connector...
https://rog.asus.com/forum/showthread.php?123891-ASUS-APEX-XIII-CPU-and-RAM-ERRRROR/page2#post833971