cancel
Showing results for 
Search instead for 
Did you mean: 

Apex XIII bios

kvarq
Level 11
0903 is officially out
probably based on beta which has been available since a month or so, not sure if it is day & night, not having too much hope though*

I am curious when dual rank will be ok with this crappy board

plus the power stuff, endless restarts, *RBAR, USB poling rate etc...

looking fwd for the KP Z590 board, can’t wait to throw this board or hit it with a hammer, can’t RMA it since Asus warranty is not at all international, money thrown down to the toilet*
11,598 Views
83 REPLIES 83

Grimpak
Level 8
installed it, seems different from the beta version. At least some menus are different, and ram OC feels more... robust?

kvarq
Level 11
I actually went page by page and menus are the same...
I think that 0903beta is the same as the 0903 "official" on Asus website...
not much is happening when "updating" from 0903 "beta" to 0903 "official", it's really short, compared when changing a bios from a version to another, there are changed lots of things, all areas are updating, aura sh*t and so on, and few restarts in between...

these are the screens from "beta" and "official" versions...
even the release date is the same (21 may)


to be honest, it's no surprise from my side, Asus support is literally minimum at best to say the least, for Apex on the QVL there are some randomly kits thrown here and there, even quad kits (mobo is two slots :P), also for Z490 they changed their mind with a bios version, stating now it's beta, then is final, other time removed a version completely eventually =))

really lost my patience already, they screwed up dual rank & stuff I think for this one...
I feel that I'm gonna smash this mobo with a hammer or something, literally money thrown down to the toilet :mad:

kvarq
Level 11
I actually went page by page and menus are the same...
I think that 0903beta is the same as the 0903 "official" on Asus website...
not much is happening when "updating" from 0903 "beta" to 0903 "official", it's really short, compared when changing a bios from a version to another, there are changed lots of things, all areas are updating, aura sh*t and so on, and few restarts in between...

these are the screens from "beta" and "official" versions...
even the release date is the same (21 may)


to be honest, it's no surprise from my side, Asus support is literally minimum at best to say the least, for Apex on the QVL there are some randomly kits thrown here and there, even quad kits (mobo is two slots :P), also for Z490 they changed their mind with a bios version, stating now it's beta, then is final, other time removed a version completely eventually =))

really lost my patience already, they screwed up dual rank & stuff I think for this one...
I feel that I'm gonna smash this mobo with a hammer or something, literally money thrown down to the toilet :mad:

morph_
Level 11
With said board, ve seen people run 3866 gear 1 super tight for DR bdie with ease...

Are you after gear 2? It seems the MSI unify is more optimised for g2 dr at this stage... Perhaps shamino/safedisk have something in the works...

kvarq
Level 11
using 10900K, no gear stuff applicable
so mad that I sold my XII...
can't use XIII properly at all...

tried the last two days lots of bios versions, testing my 2x16 stuff with GSAT
0903 is definitely the crappiest one for dual rank stability, 0106 is not bad but too rough, 0605 lasted *longer*
clearly they did something on the way...

I think I lost my patience, going to smash this garbage and re order Apex XII, while is still available in some stores...
tried for 2 months already to run this crap, don’t think they will fix this sh*t too soon

kvarq
Level 11
It’s so bloody annoying, no matter combinations I am trying to do cannot get my 2x16 running properly on Apex XIII, XMP at least.
Neither auto voltages set by XMP or lowered SA and IO ones. Bumped even the VRAM a bit, no pass.
On Apex XII this kit (4000C16D-32 GTZRA / 16-16-16-36) proved to be stable on auto voltages (1.47V SA and 1.37V IO), also lowered SA 1.30V and IO 1.25.
On Apex XIII no matter what I do, can't pass not even the included memtest :))

I tried lots of bios versions, from 0106 till 0903 beta/official, on older bioses error is reported later, but nothing is 100% rock solid.

kvarq wrote:
It’s so bloody annoying, no matter combinations I am trying to do cannot get my 2x16 running properly on Apex XIII, XMP at least.
Neither auto voltages set by XMP or lowered SA and IO ones. Bumped even the VRAM a bit, no pass.
On Apex XII this kit (4000C16D-32 GTZRA / 16-16-16-36) proved to be stable on auto voltages (1.47V SA and 1.37V IO), also lowered SA 1.30V and IO 1.25.
On Apex XIII no matter what I do, can't pass not even the included memtest :))

I tried lots of bios versions, from 0106 till 0903 beta/official, on older bioses error is reported later, but nothing is 100% rock solid.



throwing a limb here, but is it possible that your 10900k IMC simply doesn't play well with z590?

As you said, maybe the XII would be a better bet on your case, however, I would test it vs other z590 boards too.



Kinda of a long shot, but I've seen weirder things...

kvarq wrote:
It’s so bloody annoying, no matter combinations I am trying to do cannot get my 2x16 running properly on Apex XIII, XMP at least.
Neither auto voltages set by XMP or lowered SA and IO ones. Bumped even the VRAM a bit, no pass.
On Apex XII this kit (4000C16D-32 GTZRA / 16-16-16-36) proved to be stable on auto voltages (1.47V SA and 1.37V IO), also lowered SA 1.30V and IO 1.25.
On Apex XIII no matter what I do, can't pass not even the included memtest :))

I tried lots of bios versions, from 0106 till 0903 beta/official, on older bioses error is reported later, but nothing is 100% rock solid.




This Ram Kit (4000C16D-32 GTZRA / 16-16-16-36) is not support on the Maximus XIII Apex

Check the QVL list for this RAM https://www.gskill.com/qvl/165/166/1597040949/F4-4000C16D-32GTZRA-Qvl

So, when comes new 1450 bios for Maximus XIII Apex? I need that update cause my RTX 4090 stuck on pcie 3.0 bus speed. People got 1450 for Z590-E by asus support and thats the fix