cancel
Showing results for 
Search instead for 
Did you mean: 

z690 Maximus Extreme won't post, can't flashback bios

jbmerrill1954
Level 7
Hello,

My computer was running great, and I shut it down at night to go to bed. The next morning, i turned it on, and it would not post. All I get are post codes 01,20,50, and 53 with a message in the led panel 'detect memory'. There is of course no video.

I have tried clearing cmos, swapping memory modules and slots, and updating bios with flashback (which fails with a message on the led panel that says 'update did not complete'. I have triple checked that I have the latest bios file at the root of the usb stick (renamed by the rename application) and it is formatted as fat32 and is in the correct usb port on the back io panel. The flashback button blinks a few times then goes solid and the above message is displayed. I have also tried using the retry and safe boot buttons as well as switching to the alternate bios using the said button.

All I can think of is that perhaps the CPU has died (or at least the memory controller), and I have no idea how to further troubleshoot this and would greatly value any advice. My basic specs are:

z690 Rog Maximus Extreme
Intel i9-12900ks
asus rog ryunin ii cpu liquid cooler
g.skill ddr5 6000Mhz 2x32GB
asus rog strix rtx 3090ti
5xsamsung 980 pro nvme ssds
etc.....

Thanks for any help
B.
582 Views
5 REPLIES 5

ahfoo
Level 13
Try to boot your system with just one stick of ram in slot one. Once boot, go to bios and reset the bios.

Yes, I tried that, and it did not work. Thanks though.

B.

I have tried booting with just one ram stick in slot a2, and I tried both of my modules one at a time. It will not POST. Also, I was able to do a BIOS flashback by using a usb 2.0 flash drive with ONLY the bios file at the root of the drive. I have a tech coming over this morning, and all I can ask him to do is reseat / check the CPU and try to remove the plastic shroud covering the q-leds so we can read them to find what the failed component is.

Any advice is very welcome and appreciated.

Thanks,
B.

Did your technician solve this? I am having a similar problem with the same motherboard, which will not post, boot, or complete a bios flashback.

I have tried a 12900k, a 13900k, 1 and 2 sticks of RAM in each of the various dimms. I have even tried to flashback without a CPU or RAM installed, which is technically possible but also failed in this case.

I did manage to boot into BIOS twice. But typically I get nothing, or just the splash screen with 'press del or f2 to enter bios' screen (but no input is detected)

Try a partition manager to set the USB stick partition table to MBR and format to Fat32. Then reload the BIOS, rename and try flashback again. That has fixed the issue for other people. Good luck.
Z690 Hero, BIOS 3101, MEI 2345.5.3.0, ME Firmware 16.1.30.2330, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.