cancel
Showing results for 
Search instead for 
Did you mean: 

Z690 Hero Error code 50

DeusNefastus
Level 7
Hi,

I recently built my new pc with the Hero motherboard and a 12900K. The system has been running fine for a few days.
I downloaded the most recent bios from the website and followed the instructions for updating it via the flashback function. The bios was renamed with the required rename file and the instructions were followed exactly. The bios did not seem to update as I got a flashing blue light on the button, so according to the instructions I restarted the pc. Now I am getting error code 50, which indicates that there is a problem with the memory. I tried using the cmos reset button but it did not help and the memory was working fine before. Is the memory fried? I read that there have been problems with the board but then it resulted in error code 53. Any help is appreciated as I need to pc to work.
1,526 Views
4 REPLIES 4

ShannyMan
Level 7
Could you try re-downloading the 0811 BIOS and re-flashing it? I thought the light was supposed to flash for a few seconds or so while it was updating. I remember doing it on my previous board and it flashed for a bit and then stopped. Once it stopped, I would restart for the changes to take effect. Now with my Z690, I've started updating the BIOS from within the BIOS itself in the Tools menu (I believe, or maybe it's its own menu). This was a little nicer to use than the button on the back using a specific USB port. I know that doesn't help you now, but maybe next time it'll make things easier.

I tried with the most recent and least recent bios version with both renaming it to MZ690H.CAP and ASUS.CAP. It seems to work with ASUS.CAP but the other name just keeps the light blinking indefinitely. I can't get anything on the screen and I'm for sure never updating the BIOS that way again. Even when the update seems to succeed I can't get to POST, I just get a black screen and error code 50.

ShannyMan
Level 7
Are you using the Rename Utility or just manually renaming it? I almost realized it the hard way, but the Rename Utility, while simple, is designed to rename the file specifically for your motherboard. If you accidentally downloaded the wrong BIOS and renamed it yourself, that could cause some major problems. But if you use the rename utility, it can protect you from accidentally using an incorrect version meant for another board since the renamed file won't be read by your board.

Edit:
Sorry, I misread that it was posting a 53, not a 50. So glad that the capacitor issue isn't your issue.

---

Sorry man, but you probably are afflicted by the Hero Mobo issue:
https://www.tomshardware.com/news/asus-owns-up-to-fiery-z690-motherboard-flaw-starts-recall-program

Symptoms are it runs fine for a while and then starts posting 53 because of a capacitor that was installed backwards.