Showing results for 
Search instead for 
Did you mean: 

Z690 Formula Not Posting - Error Code 50/53

Level 7
Hey All,

I just went through replacement of Z690 Hero with reversed capacitor. Went with a Z690 formula since replacement was not an option, only refund. System was working great for a week or so, but then noticed one of my memory sticks (2 x16 F5-6000U4040E16GX2-TZ5RS) was not responsive to RGB controls. A quick look revealed it was actually not being detected by the MOBO or Windows. One stick was working and I was operational, so I initiated a replacement and have new RAM on the way. Two days later and now neither stick is being detected. Starting to question whether its the memory or the MOBO. Really frustrated with all these issues and Asus is not really helping much.

Z690 Formula
0811 BIOS
F5-6000U4040E16GX2-TZ5RS 2 x 16

Memory is on compatibility list. I tried re-seating in different slots and nothing will post, it just fluctuates between QCODE 50 and 53, both memory errors. I tried clearing CMOS, but can't even get into BIOS at this point. Are any other Z690 Formula users experiencing this? Is this the right thread for this? First time here and hoping to get some direction. I have PTSD over the HERO ordeal and now I am wondering, is it my board again or just the memory? I am concerned that the new memory will work temporarily like this last set did and then fail. Took me a year to get all these parts and now I've had 2 months of downtime and 2 weeks of operational time since building.

Level 7
Hi, I have almost the exact same problem. How do you troubleshoot this besides changing out the memory, cpu, and motherboard? I can't even read the q-led status because they are covered by a plastic shroud that houses the q-code led and power/reset switches. My computer is completely dead. Very frustrated and need assistance.

ROG Maximus z690 Extreme
G.skill ddr5 Tridentz5 6000
Intel i9-12900ks


Level 13
Normally this error code reflect some error with your ram.