cancel
Showing results for 
Search instead for 
Did you mean: 

Week old 3080 RGB lights stopped working (have tried every solution I've seen).

mossy7
Level 7
I know this is a common issue, but I have tried everything that was recommended in previous threads and I am still coming up short.

Initially when I installed the GPU, the lights were working perfectly fine. There were 3 red LEDs on the pcie ports, and the RGB aura lights on the card edge. Image here: Proof the lights worked initially

I just noticed today that the lights are not on and I have been attempting to resolve it myself. Initially I only had iCUE and Aura Sync installed. I did not have Armoury.

So far I have tried:

  • Uninstalling Armoury and iCUE and reinstalling updated versions
  • Uninstalling Armoury via the secret uninstall link and updating Remounting GPU
  • Unplugging the GPU/PSU/pcie and waiting 60+ seconds and then remounting & plugging everything back in.
  • Use Revo Uninstaller Pro to try and remove all files related to iCUE and Armoury Crate
  • Tried every variation of having iCUE/AC installed.



So far I am unsuccessful and still do not have anything lighting up. Another weird thing is the pcie slots used to have a red LED on each slot when the pcie cables were unplugged (3 total, one for each of the cables). Currently there is only one red LED working (the center one) when the pcie slots are unplugged.

I'm at my wits end and I really don't want to have to send the card in to ASUS to have them fix it... Any suggestions? I'd love the help.

Thanks so much!
549 Views
0 REPLIES 0