cancel
Showing results for 
Search instead for 
Did you mean: 

Usb ports not functioning properly on monitor

Danglad80
Level 8

Hey,

As a bit of background I formation, I have a Rog Zephyrus Duo 16 and bought a Balteus QI. I have the power cable plugged into an outlet on the wall, and usually plug in the USB connector into my laptop which is so the RGB works and just unplug it if I have to take my laptop anywhere.

I just bought a new monitor for the first time, a 34 inch Samsung LC34J791WTNXZA if it matters, it has 2 USB ports in the back and I wanted to replug the Balteus QI, so I don't always have to unplug it. I plugged the USB for the power supply in first, and tried the wireless charging and it worked fine. However, when I plug in the USB for the RGB, nothing happens. Since then I tried to use a USB to USB-C converter and plug it in like that into the monitor, but still nothing. I tried the same steps on the laptop and it worked without an issue. During all fo this, the monitor was connected to my laptop with a thunderbolt 3 USB-C connection. So I thought maybe I should use the USB pass-through part of the Balteus QI, but still nothing.

Could someone help me figure this out?

Thanks in advance!!

72 Views
0 REPLIES 0