Showing results for 
Search instead for 
Did you mean: 

USB 3.0 Speed is too slow on Hero X M/B ?

Level 7
Hi all,
I have a problem with the speed of my USB 3.0
on my Asus Hero_X M/B.
Running both Windows 10 & 11

I am only getting transfer rates of about 38 MB/s at it's fastest.
The same USB stick used on my ROG Laptop gets speeds of 138 MB/s

My System is:
Intel Core i7 8700K
GeForce GTX 1080 Windforce 8GB Card
Samsung SSD 960 EVO 1TB PCIe NVMe drive
Samsung SSD 970 EVO Plus 1TB PCIe NVMe drive
Corsair Vengeance LPX 32GB
BIOS version: 2701 Date: 07/13/2021

I have tried plugging the USB stick into all the sockets on the front and back of the PC,
I also have some USB C sockets. They all return a speed of around 38 MB/s
I have uninstalled the USB Drivers and reinstalled.
I have checked the BIOS to make sure they are enabled.

Has Anyone got any Good suggestions in what might be wrong with the system?
Thank You......

I have just updated my Post here:
I installed Linux Mint to my PC
and the USB key is transferring data at 200 MB/s
So it can't be a hardware problem!
I would say it's a windows problem?
Drivers ?
Windows says it is using the best USB drive ?
I am Stumpted ??

It sounds like that USB stick is running at USB 2.0 speeds. Either it's a driver issue or that stick is not entirely compliant with 3.0 spec. If possible I would try a different 3.0 drive to see how it behaves.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Level 7
xeromist , you are 100% correct,
It is the USB sticks which are faulty.
Tried them on a laptop,
which gave the same results, 38MB/s
As a warning to other people, here is the
model of the USB Sticks

Ultra-Dual Drive
Go 64GB
for USB Type-C devices an A Connections.
Up To 150MB/S

Here is the link the them:

I shall be returning them as "not advertised as such" !
Thank you, Happy New Year.........

Level 7
Hi all,
As I started this post I thought I would
Close this topic as I have found the answer
To my original question.
And the answer is:
Ultra-Dual Drive
Go 64GB
for USB Type-C devices an A Connections.
Up To 150MB/S

Is incompatible with windows 11.

I showed this by installing this USB3 drive on a Linux Mint O/S
And it was absolutely flying.

On the Windows 11 the best I was getting was 38 M/Bs
Not much faster than USB2.

On the Windows O/S I inserted a Corsair Voyager GTX USB3 Stick
And got huge data write/read speeds.
And for good measure I inserted a SanDisk Extreme USB3 Stick
And got huge data read/write speeds.
So there we are.

So, do not buy a
Ultra-Dual Drive
Go 64GB
for USB Type-C devices an A Connections.
Up To 150MB/S
if you want to use it on a Windows 11 PC !!
I hope you find this article useful?