cancel
Showing results for 
Search instead for 
Did you mean: 

Troubleshooting GPU upgrade

ramack19
Level 7

The system

The MB: ASUS B450-F ROG STRIX Gaming AMD AM4 ATX Motherboard PCIe 3

CPU: AMD Ryzen 5 2600X 3.6GHz 6 Core AM4 Boxed Processor

Corsair cx-600 Power Supply. (yeah, on the low side)

32Gb RAM

Original GPU: GeForce GTX 1660 Ti GAMING X 6G PCIe3

 

Card 1 MSI NVIDIA GeForce RTX 3060 Ventus 2x Overclocked Dual Fan 12GB GDDR6 PCIe 4.0

Card 2 Gigabyte GeForce RTX 3060 WINDFORCE OC Overclocked Dual Fan 12GB GDDR6 PCIe 4.0

 

This system has worked flawlessly for 2-3 years. I bought my son a GPU upgrade for Christmas. The first card upgrade(card 1) was installed, never worked. Got the Award BIOS beeps indicating no video card installed or bad card. The original GPU was swapped back in and it worked. I assumed I got a defective card, so I returned the card to the store and exchanged for Card 2.

 

Card 2 was installed. It worked for 4-6hrs, then the PC was powered off. The next morning, powered on the PC, got the BIOS beeps indicating a defective card or not installed. Swapped back to the original GPU, works fine.

 

Any ideas why a new GPU won't work? The only thing I can think of is PCIe 3 vs PCIe 4 compatibilities. But my understanding is that PCIe are backward/forward compatible.

160 Views
3 REPLIES 3

ramack19
Level 7

Another thought, the BIOS is not current, could that be a cause?

Having a similar issue and the problem was CSM not enabled.  Bios with CSM disabled throws those startup beep error indicating a VGA problem.  Bios after clear CMOS shows that VGA card isn't UEFI compatible and thus enables CSM.

dja2k,

Thanks for responding. I'll check out the CSM setting. I'm sure that issue was with the BIOS, I flashed the BIOS to the most current release and the graphics card was recognized. No more issues with that. However, multiple times while rebooting, the OS(Windows 10) goes into a repair mode and restarts again. Sometime it will then go into the desktop, other times it will go into repair mode again.

But, in general, the flash resolved the problem. I'm wondering now, if the CSM setting is what's causing the repair problems.