Showing results for 
Search instead for 
Did you mean: 

So BSoD overnight C Drive became D, D became C after DISCPAR ....

Level 7
Hi all,

Do we have any knowledgeable bods that could help out this odd problem, a few moments to pull me out of a BSoD screen on one of the first ' VR READY ' PC's the G20CB, bough here in the UK around the time that the early batch of rifts went on sale ( 1st or 2nd batch)

Could anyone with a similar machine take a look at you're / generic BIOS settings to see where where I've messed up .... (as I've tinkered a little bit with mine after it refused to boot up Saturday)

So briefly so you get an overview ...

System similar G20-CB, same proc 6700, I'm on a 970 GFX card.

Main Drive, SSD 128G I believe, C drive,

Installed a couple of programs for a Vuze 360 camera Thursday night, played some elite dangerous Friday, Saturday out filming turned on Sat evening .... BSoD .... Sunday, spent most of the day trying to breath life in system.

Errors, were varied from a 0000001 / e or f .... (Could access command prompt as windows tried to repair)
Noticed that the C drive (system) and D drive (data) somehow had been swapped ... which would explain the 'cant find operating system'
So used some command prompt instructions to view disks (0 and 1) with volumes (1 to 5 I think) on system , renamed 'C' to G Drive, changed D back to C (system with windows folder) then G back to D drive (Data)

Another command to 'rebuild' table etc ..... completed.
Rebooted .... didn't fix the issue.

Tried to disable the Data Drive in BIOS to force only available drive (System) to be just that, and I think that's where things got a bit messy and I started going cross eyed.

Also, I can't get into the windows option which gives me the ADVANCED .... COMMAND PROMPT window either ....
The list of F1-F9 actions (safe windows .. with command prompt, network .. lower graphics .... ) appear, but don't seem to do a thing when the system reboots after selecting.

So ANY help you can give me with how the BIOS settings should be on a standard build would be greatly appreciated, because I've lost myself.

As I mentioned in the post, I havent cracked open this beast as yet to physically force the hardware to look at the true boot (C) drive. I'm hoping / assuming this is 'a settings in software issue'.

I've got photo's of the BIOS I took this morning too, that I could pass on if that helps....

I haven't tried the 'USB Recovery' option yet, I'm going to pick IT's brains here at work, see if we can shed some light over it all. [-Edit today, I've brought the PC into work, IT are scratching their heads, and have provided me with the windows USB tool which I'll look at in a couple of hours)

Hope its back up and running for the Elite dangerous thing this week ......

Greatly appreciate any help you can provide with links, BIOS standard settings, and man do I now know windows does NOT set Restore points automatically !!!!

Any thoughts, tips, comments, constructive criticisms .... (I've had ASUS Laptops for 7 years, it will be an interesting time getting back to the old 'get your hands dirty and lift the side off' back to basics .... Last time I built a computer, you had jumpers on a mother board and spend half your time swearing at config.sys and Autoexec.bat files .... Damn you HIGHMEM)

After this, I think it will be the perfect time to install the 1TB SSD as System disk once I've got the data off the old one !!!

All the best, D.

Level 10
I'd disconnect the drive that isn't the OS drive, see if it boots that way. It sounds like you did some unnecessary changes that may have made things worse with attempting to change drive letters manually, but only time will tell.

BIOS...did you change anything right before this stopped working? AHCI to RAID mode or vice-versa? If not, why touch the BIOS? Wasn't it working perfectly before with the same settings? There's also factory defaults, but, these PCs don't have much in the way of settings to really break anything either. It's not like you are manually changing voltages or overclocking anything.

The only other BIOS setting that comes to mind is UEFI vs Legacy mode. Ours come stock in UEFI, that's why you see the ASUS logo during Win10 boot. If you installed UEFI, you are stuck UEFI and it must be set that way, same with Legacy mode (which you'd see the Windows logo on boot).
Asus G20CB - Core i7 6700, Nvidia GTX980, 16GB Ram, 256GB SK Hynix SSD, 1TB Samsung SSD.

Thank's for your reply,
That was the damndest thing .... I haven't tinkered with the PC at all since I got it, it was a huge step up from the G74 laptop.
Didn't touch the BIOS, had the occasional crash in heavy games, but then with both Oculus and Vive drivers and checking to see if their respective headsets were in .. expected.

The only thing that I'd installed pre BSoD was the drivers for the 3D 360 Camera, the Vuze .... now these drivers were DL'd from the vendors website, and Norton had a bit of a 'this is suspicious' very few norton users have downloaded this file ... which I skipped (Its a VERY new camera).

the software worked alright, took my first 360 video, stitched it in the newly DL'd software .... stuck it in the rift, and it worked, powered down, next day asI said, shot some footage, turned on the computer in the evening , no OS found.....

Mate looked at the settings and drives and I'd noticed that System drive was re named as D, and Data drive that was D now C (With no OS on), he did a few command prompts to try and fix ... nothing ... after a while .... didnt even give me the option to (without a key) drop out to command prompt.

Yesterday, took it into work, to the IT bods, and they scratched their heads.

Any how long story short, they created a windows win10 usb, which allowed me to get back to the command prompt ... I disabled the Data drive that had been renamed to C: .... forcing the system disk that was D:, to be given the c: name once again.

I'm copying the data off the C drive (SSD System) using robocopy to an external drive ....
I've done the classis dir *.* /s > CdriveContents.txt reference so I know what was there ... same with D drive when thats plugged back in, and I'll try and let windows fix the issue. With the option which should revert whilst keeping data .....

Oh one last thing .... thinking that the c drive may not be marked as the system drive anymore (why else would it be nudged to drive letter D when another disk is present, I used some commands in Diskpart to assign as the primary ... it came back as saying it couldn't be done ..... which was odd.

Well its 2am, I'm shattered after being kept up til 4am yesterday without realising (work starts at 9am ) so an earlier night tonight....

any help appreciated.