cancel
Showing results for 
Search instead for 
Did you mean: 

rog z690 maximus extreme, 3090ti at x8 instead of x16

jbmerrill1954
Level 7
Hi,

My GPU is only running at x8 instead of x16 link width according to the bios and cpu-z. I have all m.2 nvme slots populated including the dimm.2 card, (total of 5 nvme drives), but no other pcie slots populated other than the GPU in slot 1.

Is there any way I can get the GPU to run at x16 without removing nvme drives?

My CPU is an i9-13900ks.

Appreciate any advice.

B.
490 Views
2 REPLIES 2

jesswade
Level 8
If your GPU is only running at x8 instead of x16 link width, it is possible that it is being affected by the other NVMe drives that are occupying the PCIe lanes on your motherboard. Here are a few things you can try to get the GPU to run at x16 without removing NVMe drives:

Check the motherboard manual: Some motherboards will automatically switch to x8 mode when multiple M.2 slots are populated. Check your motherboard manual to see if this is the case and if there are any specific configurations that allow for full x16 operation.

Switch the GPU to a different PCIe slot: If your motherboard has multiple PCIe slots, try moving the GPU to a different slot. Make sure to consult the motherboard manual to ensure that the new slot supports x16 operation...

Adjust the BIOS settings: Some motherboards allow you to manually configure the PCIe lanes to prioritize certain devices over others. Check your motherboard manual for instructions on how to adjust these settings, and try allocating more lanes to the GPU..

Update the BIOS: Make sure that your motherboard BIOS is up-to-date with the latest version, as this can sometimes resolve compatibility issues that affect PCIe operation.

Hi,

I just noticed the above reply to this post.

The issue, for anyone else facing this problem, is due to having the m.2_1 populated with an nvme drive. This disables pcie_2 as well as lowering the link width of pcie_1 to x8. It is not completely documented in the manual, but I found posts and confirmed with technical support that this is the case. From what I have read, running the GPU at x8 does not significantly reduce the performance, so I am glad about that. I will continue to run at x8 with m.2_1 populated.

Thanks for your help and advice.
B.