cancel
Showing results for 
Search instead for 
Did you mean: 

ROG STRIX will not POST no QLED activity

Triptronix
Level 7
I put together a new system a week ago using the B350-i mini itx board and was able to boot into the bios menu where it picked up my CPU, memory and storage information. Attempting to plug in my keyboard the system crashed. I couldn't power down at all so I pulled the power cord. I waited a few minutes, plugged the power cord back in, the board RGBs come on like normal, the board light indicating power was on so I powered up the system up. Only the fans turn on (CPU and case fans) but the GPU fan would spin for a few seconds then stop and repeat, no POST beep codes and the QLEDs are no longer active, no sequence of lights at all. I have already gone through tomshardware POST troubleshooting steps and switched to 3 working PSU, tried an additional working GPU and the system still refuses to boot. When searching google I only come across two other people having the similar issue but there was no solution or firm indication of what the problem could be. I'm thinking the board is faulty. Any additional steps or recommendations I can take on this? Thanks
788 Views
2 REPLIES 2

Chino
Level 15
Have you tested the motherboard outside the case? Use the cardboard box as a testbench. See if there's any new development. 🙂

Chino wrote:
Have you tested the motherboard outside the case? Use the cardboard box as a testbench. See if there's any new development. 🙂

Thank you for the advice but I have tried this several times with no luck. Any other suggestions?