Showing results for 
Search instead for 
Did you mean: 

ROG STRIX B650E-I wont post/boot

Level 8


I've just built a new PC with the ROG STRIX B650E-I motherboard but I'm not able to get it to boot.

It all turns on, motherboard, fans, gpu, everything thats meant to light up or spin seems to be doing so, but I get nothing on the screen. I've tried both HDMI & Display port on my GPU & I tried the HDMI on the Motherboard.

The Q-LEDs on the board flash red, flash yellow, flash white, then stay GREEN. 

The general Q-LED help said to check the SSD, but before I take it all apart, I thought I'd double check. 

Is this an issue that could possibly be fixed by a BIOS flashback? I planned on updating the BIOS once I could get it to post but I've read that some of these boards wont work with some CPUs without BIOS being flashed first. My CPU is a AMD Ryzen 9 7950x.


Super Moderator

Hello and welcome,

Have you attempted to remove the GPU before attempting to use the IGPU - plugging into the HDMI on the motherboard's rear IO?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 8

Thanks for the reply.

No I have not tried removing the GPU, is that what you'd recommend as a test?

In order to correctly test if you're able to get display-out from the iGPU, yes.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 8

I went to work on it today, and I thought I’d just turn it on to double check, and what do you know.. it posts. 

I got a logo briefly then this error message

New CPU installed, fTPM/PSP NV corrupted or fTPM/PSP NV structure changed.

Press Y to reset fTPM, if you have BitLocker or encryption enabled,
the system will not boot without a recovery key

I pressed Y, it reboots & now I’m in BIOS. All very strange.

It recognises my RAM & NVME storage, CPU is at a steady 40*C. 

It seems to be running ok, so I’m going to update the BIOS & cross my fingers it stay that way. 

Level 8

What is my luck.. BIOS updated failed. 

“BIOS update failed!
Security verification failed.”

Now it's locked up on the failed screen, the mouse is unresponsive, enter key doesn’t get a response either.


Ok. Rebooted & tried again with a diferent USB & it seems to be updating. Fingers crossed 

BIOS update compete. 😅

Cool. Crisis averted. Remember, don’t apply EXPO/DOCP/XMP profiles or overclocking when using EZFlash. Clear the CMOS prior to updating the UEFI

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 8

I think I have it up and running now. Thanks for the help. 

I now have BIOS 1616 (ROG STRIX B650E-I GAMING WIFI) running and windows installed, it seems to working.

Can I now enable EXPO safely? I know some people reported issues running EXPO with some of the latest Ryzen CPUs, is that fixed in this version of the BIOS or should I still be cautious? 

No reason to be cautious. Just make sure to test stability and tune the system accordingly if needed.

I normally recommend Karhu Ramtest for this purpose, but you can do some preliminary stability testing in the UEFI with Memtest86.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

I finally decided to turn on EXPO & now my PC won’t boot anymore. 

I managed to get it to boot once, but it took a long time but eventually went straight into Windows sign in. I checked in Window ps if the RAM was now running at 6000 & it was. I thought maybe it was just RAM training that cause the lengthy reboot, so I tried rebooting again. 
This time it took longer, still no ROG/ASUS screen, straight into Windows sign in. I loaded the ASUS software to see if it reported anything abnormal but it seems ok. I ran it's simple stress test which it said was successful. 
So I tried rebooting one more time & now I can’t get it to post or load into windows. It's got stuck on GREEN led, ORANGE led & no led. I've tried hitting delete to enter BIOS but no luck there either. 

What should I try next? How to revert it back to EXPO off. Am I ok to leave it retrying to boot for a long time or can it over heat if left?