Showing results for 
Search instead for 
Did you mean: 

ROG STRIX B650E-F gaming wifi will not post with 2 DIMM

Level 7

Hello forum.

I've got a brand new build with this mobo and I'm trying to get it to work with 2 sticks of DIMM.
The sticks are G.Skill Flare X5 DDR5-6000 16x2

When trying to input them together in the recommended configuration of A2-B2, I get a yellow (orange?) light on the DRAM LED on the mobo. 

Both sticks individually work in the A2 slot. However, neither works in the B2 slot.

Here are some steps that I've gone through to try and solve the issue:
updated the bios to 1616, reset CMOS and tried to utilize one and then the next to get the memory to post. I've waited on the memory to post with a single stick in the B2 slot ( a hint that I read on Reddit) for over an hour. I've tried to get both to work together at periods for over an hour and without fail, the bios and OS will not load and I am stuck with a yellow light.

I'm unsure of how to proceed, aside from RMA'ing at place of purchase.. Which I would like to avoid.

Any tips or fixes are greatly appreciated.


Super Moderator


could be a contact pressure issue. Reset the CPU and cooler whilst making sure to check for socket pin damage and even cooler mounting pressure. Retest with both modules inserted correctly.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 7

Hi, I'm having the same problem with my build (Corsair Vengeance RGB, DDR5-6000 32x2). Did you ever manage to solve the problem?

Any replies/solutions are greatly appreciated.

I tried every solution I could find under the sun, including silent _scone’s solution, and nothing resolved my issue. I ended up returning the board and got a replacement of the same board, and that board works great. So I never did find a root cause. 

i have the same F problem.

i try changing the PSU and RAM, even Windows 11 to Windows 10.

I try everything but i think you should downgrade your bios to version 0821, that what i did and it seems my problem has gone... 1 day testing and no restart or shut off.

Forget my fix, again stuck on restarts