cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Maximus VIII Formula

Avantis
Level 7
Hey guys, I'm new to the forum but I seem to be having an issue that I can't figure out. Really hoping I can get some help since I've tried calling ASUS and they can't really be much help to me at all. If I don't find any help I'll end up sending out my MOBO since I still have warranty on it. So basically, I've had my Formula for about 9 - 10 months now (bought it Nov. 2016) and everything has been working fine up until about a week ago. I started up the PC 5 minutes after shutting it down and out of nowhere my USB ports stopped working (only 3/12 ports work now, 4 of the ports not working are located on the PC case), my bluetooth stopped working (can't turn it on through Windows), and for some reason my mobo is not detecting my Corsair H115i, but the water pump is still running and I can see the speed of the pump, but every other fan speed says 'NA' in the BIOS but are still running fine. Not even Corsair Link detects my H115i and I have the latest version of Corsair Link. I have 2x16 Ram sticks on the build, both are working fine. It's not a memory issue and I've never overclocked the unit. I updated all my USB and bluetooth drivers, I even updated the BIOS to the latest version. Tried resetting the BIOS and even tried repairing Windows. Nothing worked. I think the H115i problem could be with Corsair Link but as far as my bluetooth and USB ports go, that's what truly concerns me.

--------------
Intel i7 6700k CPU
ROG Maximus Formula VIII
Corsair Vengeance DDR4 2x16 GB RAM @3200
Samsung 960 Pro M.2 512 GB
Corsair H115i Hydro Series
EVGA GTX 1080 FTW Edition
EVGA Supernova T2 850W 80+ Titanium PSU
Corsair 750D Obsidian PC Case
1,111 Views
0 REPLIES 0