cancel
Showing results for 
Search instead for 
Did you mean: 

Rampage V Edition 10 and Samsung 960 Pro M.2

Woelund
Level 7
Hi,

after a weekend of a very successful build together with a friend (thanks a lot to the Pros posting How-Tos on this Forum - helped IMMENSELY !!) I would have a follow-up question regarding the recognition of a Samsung 960 Pro M.2 card on a Rampage V Edition 10 board:

We put the card on the board and first time booted into Bios. Everything went very well. The 960 PRO was available (even though it had not been prepared in any way ... at first I was thinking that it would have to be GPT formatted already. That was not the case.) and was recognized by the board. I then set CSM to disabled (as described in the very good How-To: https://rog.asus.com/forum/showthread.php?76993-Guide-How-to-install-windows-8-8-1-10-The-proper-way... ) and we booted to the UEFI Win 10 installation USB stick. During this boot I noticed that the Bios reported "Reenabling CSM because ... (something)". The Win 10 install environment came up and we nicely select the M.2 as install target. Everything went perfectly well.

Later, from Win 10. we updated the Bios and subsequently had to go in and set the boot device anew as well as the RAM speed etc. I noticed that the board now showed the following options as boot device:
"Samsung 960 Pro"

"Windows boot manager Samsung 960 Pro"

I selected "Samsung 960 Pro" but it would not boot from there (with CSM enabled) .... blinking cursor showed up on the screen, if I remember correctly.

I then went back into Bios and switched off CSM again and selected the second option "Windows boot manager Samsung 960 Pro". During the subsequent boot the Bios would again write on the screen "Reenabling CSM because ... " and it would boot nicely into the WIn10 on the M.2.

Questions:

1) Is it normal that the Bios reenables CSM automatically ? Is it maybe not necessary to switch off CSM in the first place when working with an M.2 on the Rampage V Edition 10 ? Or is this expected and necessary Bios behavior ?

2) Is it normal for the Bios to not show "UEFI Samsung 960 Pro" , but instead show "Windows boot manager Samsung 960 Pro" ? (I would have expected to see "UEFI Samsung..." as boot option.)

Luckily the system runs well now, so this is more out of curiosity that I am asking.

Thanks !

Woelund
6,046 Views
5 REPLIES 5

Menthol
Level 14
Nice system
Windows boot Manager is normal and expected on a UEFI install. I don't know about CSM automatically changing as I use CSM enabled because it is necessary for a Win 7 install
Hopefully someone has a concrete answer for you but as long as everything is running correctly nothing to worry about

I have the exact same boot configuration you do, 960 Pro M.2 (1TB) over a RVE10. I have never tried to disable CSM, either when formatting with Windows or afterwards, so I have it enabled and kept so. So anecdotally I can't tell you if it would've forced me back into CSM mode.

However, as I understand it certain boot options require it, so for example you would've had to have CSM enabled in order to install Windows from the USB stick. Thereafter, if your boot sequence allows for a DVD boot or a USB boot in the sequence, then I think it will also force CSM on you. Just my understanding of it.

Yes, the boot manager should be the first in your boot sequence and the M.2 drive should be after that somewhere. In my sequence I stuff a DVD boot drive in between the two of them. But if you have no other drives with which you want to boot up, then you could try just having the boot manager then the M.2 drive and only those two, as options and see if CSM stays disabled. Caution, however, that if you can't get into the BIOS for some reason to change it, then if your M.2 dies you have no real options left but a reformat.
Davemon50

Hi,

thanks for the answers. Generally the system runs stable and very nicely now - so this is really more for enlightment and my own enjoyment. Regarding CSM: since the first time I tried to boot into Windows after the Bios update I selected the incorrect boot option ("Samsung 960 Pro" instead of "Windows boot manager Samsung 960 Pro") I cannot really say whether or not disabling CSM caused any problem. The boot failure at that time must have come from selecting the wrong boot option, and most likely not from incorrectly setting CSM. Unfortunately I did not debug that enough to know for sure ... I now assume that:

a) CSM (at least on the Ram V Ed 10) does not have to be disabled during a system install. Perhaps this is true only for older motherboards.
b) CSM apparently automatically enables itself when necessary. (How exactly the motherboard determines that escapes me at the moment, but in retrospect I am happy it does, because otherwise I probably would have had a lot more problems.)

Thanks for clearing up the boot option naming as well. I was a bit confused on first sight, because I expected "UEFI ..." and instead I got "Windows boot manager ...". At first I wanted to argue that "Ah, this is because it is not a SATA drive ..." but then I realized that UEFI formatted USB sticks also appear as "UEFI ....".

Alas - the main thing is that everything is nice and stable. I think I will look a bit more into what exactly CSM is and does ... just to understand a bit more about it.

Thanks for the info !

Woelund

Hi,

as a follow-up: a bit of research cleared up the mystery regarding the re-enabling of CSM (Compatibility Support Module - supports booting legacy OSs from GPT formatted disks or - see below - non UEFI supporting optional ROMs from cards):

What I did not mention is that the system (for now) has an old Radeon 7970 installed. Its OptRom does not support UEFI - I even found a thread to that extent https://rog.asus.com/forum/archive/index.php/t-49019.html - and thus CSM has to enable itself, if the motherboard is to report anything to the screen, because the OptRom from the graphics card is loaded during boot time, in order to write to the screen.

Problem solved - 🙂

Woelund

I'm glad you got it solved and have a stable system.

I took two of those Radeon HD 7970's out of my computer when I rebuilt recently. Those were pretty good performing cards, my only complaint with them was they were a bit noisy during gaming as the single fan would ramp up to some loud speeds. They are now sitting in a box, lol.
Davemon50