Showing results for 
Search instead for 
Did you mean: 

Rampage IV formula - what this means?

Level 7

My computer is having an odd behavior when I try to power it up. It doesn't start up at all, it doesn't make a sound.
Only start, reset and clr cmos buttons are blinking. All at the same time like once in a two seconds or so. And the
debug leds are not lit at all, so I can't troubleshoot using them like usually. So what does this mean? Is my Rampage IV
board fried now or what? I have had the same bios settings and everything for the last 4 years so nothing has been
touched before this started.

I have tried if the computer is in sleep mode, but no. I have removed the battery from the motherboard to reset the settings and
also pressed the clear cmos, start and reset buttons, but nothing happens. Not even a beep.

I have also tried a new PSU and GPU and I have removed and reattached drams and GPU. There is not much to do, but if someone
knows why those start and reset and clr cmos buttons are blinking please tell me.
Otherwise this would be my third broken
Rampage board.. And the warranty is outdated already, of course just in time.

MOBO: Rampage 4 Formula
PROS: Intel i7 3820
PSU: Corsair 1000W and 650W

Level 40
Sorry Piste...your post seems to have gone unnoticed 😮

You sort anything out in the meantime?

Does sound like the board might have died if you have tried another PSU and the other steps.

Sometimes hard to tell if board or CPU though...sometimes comes down to being able to substitute one of these..