Showing results for 
Search instead for 
Did you mean: 

No Post with X570-F w/ Ryzen 9 3900x

Level 7
I am at a loss. At first I thought it was the PSU. It was an 850watt. I have both the 4pin and 8pin CPU plugged in and was not getting anything. When I bumped it up to 1000watt, I get the LEDs over the back panel to light up as soon as I add passive power. I have the Board outside the case with CPU and AIO connected only and I get no post beeps. Without Memory I should get that to code. I thought...perhaps it needs a fan, so I added the stock heatsink fan into the equation...still no post codes. I thought well heck, I guess I toasted the board and ordered another...and sure enough, it is doing the exact same thing. The BIOS' are 3602 and 3603 and for the 3900x it is only required to have 0268 so I have not attempted to Back Flash the BIOS.

Ideas as to what could be the cause of this?

Super Moderator

Having replaced the board already the most likely culprit will be the CPU. Save potentially damaging another board, if possible I would take it to a system integrator and get them to test this for you.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 7
Well, not the CPU unless I am having the worst luck at getting CPUs from AMD. Just got a 5900x, which requires the bios version to be 2606 and nothing has changed...

Well, it turns out my 8-pin cable was not making a good seat with the PSU. It is a modular PSU. I got a PSU tester and that worked with the 24pin and the 4pin, but would not work with the 8pin. That is what sent me looking for the why.