cancel
Showing results for 
Search instead for 
Did you mean: 

New build won't boot up.

Rob_W_
Level 12
Hi .
Having torn most of my hair out now I thought my best bet would be to pose the question on here.
I have just finished this rig but it won't boot up, all I get is a light click noise from near the back outputs.
The mb start, reset buttons light up and the bios led, I have no LEDs showing on the case or power swch,
Tried removing all drives , still no go so have taken mb out of case and connected power to ATX and the 12 v ATX connectors, mouse and keyboard, monitor, and still just a light click again,
Problem isn't helped by the user manual, which bears no relevance to the actual positions of connectors on the mb or there labelling, the instalation manual on disk is even more unhelpful.
Starting to think I've got to start the process of returning my for replacement but I'm hoping it's just me being dim and missed something, any comments would be a great help.
Thanks
23,784 Views
33 REPLIES 33

NemesisChild
Level 12
Are all of the components brand new?
What error code are getting?
Try posting with only one stick of memory installed, switch different slots.
Did you remove the CPU to check the socket for bent or broken pins?
Double check your PSU cable connections to the board.
Try posting with all USB and all drives disconnected.
You might even try removing your 980Ti and attempt posting with the iGPU.
Intel i9 10850K@ 5.3GHz
ASUS ROG Strix Z490-E
Corsair H115i Pro XT
G.Skill TridentZ@ 3600MHz CL14 2x16GB
EVGA RTX 3090 Ti FWT3 Ultra
OS: WD Black SN850 1TB NVMe M.2
Storage: WD Blue SN550 2TB NVMe M.2
EVGA SuperNova 1200 P2
ASUS ROG Strix Helios GX601

Rob_W_
Level 12
All components brand new.
Display for error code not lighting up, standard 88 shows up.
Will try just the one memory module, not tried that yet.
Removed cpu checking that tomorrow .
Psu cables checked and verified.
Tried without any drives connected, same problem, also removed GPU, still no joy.
Looks like might be phone call to Asus tech: dept tomorrow , but for now will try the memory and check cpu.

Chino
Level 15
Do the following then report back your results.

1. Inspect the CPU socket for any bent or missing pins.
2. Use the cardboard box as a testbench.
3. While installing your heatsink, don't overtighten the screws.
4. Make sure you've connected the 8 pin power cable along with the 24 pin power cable to the motherboard.

Rob_W_
Level 12
Hi .
Found the problem, some of the socket pins bent! Took great care assembling it, placed in assembly tool, all seemed to install nicely, could not say if it arrived like it or whether it was during assembly but it doesn't alter the fact they are bent.
Because the pins are of a sprung leaf style (or whatever the term for it is) it makes them difficult to straighten, have started by using 2 fine needles, having insulated most of the needle, have managed to reshape a couple of them but I fear it might be a case of returning to Asus for repair or renew, could be costly I think, not good paying out 450€ twice???😢

Nate152
Moderator
Hello Rob

Good to see you found the problem, I've seen people here with bent cpu socket pins straighten them with success if only a couple are bent.

How many pins are bent?

You can use a round wooden toothpick to straighten them too.

Rob_W_
Level 12
From initial work it looks like probably 7 pins to work on, just watched a couple of very good vids on utube on how to streighten / realigne bent pins, given me hope
To continue with it first.
From vids have now sorted very fine screwdriver and toothpick, not forgetting very bright light.
Have a few photos of damage, I will post a befor and after if all goes well.
Thanks for suggestions and help.

Nate152
Moderator
You're welcome

Take your time with it and make sure they are all evenly spaced and look in order, you can do it. Be careful not to bend any of the other pins.

And yes please post all the pics you like of your cpu socket from all different angles.

A magnifying glass can help too.

Chino
Level 15

Rob_W_
Level 12
5485654855well that didn't work, repaired the pins straightened them with compass needle in the end and nudged them into line using the back edge of a craft knife to get lines straight, worked quite well I thought(attached some photos) and still no life at all, contacted asus technical this morning but you cant talk to them, had to be done by email, would have been easier to talk to someone, still will wait for there reply.
could the bent pins have wrecked the processor or caused other damage preventing startup.


getting depressive looking at 2800euros worth of dead components...