Showing results for 
Search instead for 
Did you mean: 

New Build - ROG Z690-E/i7-13700k - No Display on Initial Boot Up

Level 7

I just finished this new build (its the 5th gaming PC I've built over the years) with an i7-13700k and compatible G.Skill RAM. Before starting it up, I updated the BIOS after following the ASUS BIOS Flash instructional video and am convinced I did it properly. Upon initial startup for the first time, there is no display. All fans and lights are working. I made sure the card (Gigabyte RTX 4090) was fully seated, I then opted to swap out the 4090 with my working 1080 card and still no display. Afer reinstalling the 1080 in my other rig, I started it up to confirm my cable/monitor hadn't suddenly gone bad.

Not sure what to do at this point besides pouring through forums looking for help and/or getting on the line with ASUS about this board.  

Any suggestions would be greatly appreciated. Thank you! 


Level 7

FIXED - What the issue turned out to be was not a fully seated RAM stick. Even though the locking clip was closed, the stick was somehow not fully seated. I removed both and reseated them and it fixed the No Display issue. 

Level 10


Most likely something went wrong while updating the BIOS. Probably it went corrupted. Download the user's manual from the Asuses website and follow the instructions using the BIOS Flashback option. In the manual, it's section 2.2. You have to implement a previous version of BIOS that worked from the start. Let us know the progress 🙂