cancel
Showing results for 
Search instead for 
Did you mean: 

Motherboard turns on, but not BIOS

Tokin_JOO
Level 7

After swapping out a new motherboard, CPU, and RAM, my PC won't display anything when turned on.

The motherboard and fans all turn on, but I do not hear any beeping when trying to boot up.

It briefly stalls on Q code 12 then swapped to Q code 54 then right to Q code 55. With an amber light above the Q Code display.

I've assembled, disassembled, checked all cables. Reseated the CPU and AIO cooler. Motherboard CPU pins do not look bent or dirty. I've reseated the two ram sticks. Tried all the different slots and each slot with only one ram stick.

I've tried pressing the CMOS with the PC powered down and unplugged.

I've done a BIOS update via the BIOS flashback with a USB drive.

I'm at a loss on how to move forever here. Would really appreciate any and all feedback.

Component list;

I9-14900k - CPU

Asus rog strix z790-e gaming wifi - motherboard

Corsair H150i pro - AIO cooler

Corsair Vengeance DDR5 6000 MHz 16GB x2

78 Views
0 REPLIES 0