cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus XI Extreme LAN Issues

LazyGreek
Level 7
Hello, I'm hoping to find some help. This is the 2nd board I've received. RMA'd the first one with customer service thinking its a hardware issue. I've tried both the 1g and 5g LAN ports, the WiFi LAN. I cannot get more than 20 Mbps download, and maybe 2-3 upload. Steam downloads take forever, I've had Spectrum come to the house to test the modem, they pull the full 100+. My Wifi devices (iPhone & iPad's) also pull 100+ on speed tests. I've tried updating the BIOS to the latest, the LAN Driver's to both the 1g & 5g ports. replaced my LAN cable with a new Cat 6 cable. What could the issue be ? My last board was an ASUS Rampage IV Black Edition, and I had no issue's. Just unboxed, installed and booted. Same for this new board.

I have the board paired with an i9 9900k & 2080ti card.....

I've tried searching this forum, googling. And advice would be a help.
1,225 Views
2 REPLIES 2

LazyGreek
Level 7
I figured it out.... It was the program called GameFirst that was installed in the AI Suite !

JohnnyFire
Level 7
hey there can you help with one thing? is it possible to backup the firmaware of you aquantia lan and send it to me? it very important to fix mine