cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus XI Extreme I/O Shield Preventing Board Installation

MAtoms
Level 7
Maximus XI Extreme I/O shield does is not allowing me to install the board in my case. The screw holes are too far towards the front of the case to be able to install a screw in the left middle and top. The shield is what is preventing me from being able to move the board towards the back any further. Have tried two other ATX boards that do not have a pre-installed shield, and they are able to be installed.

I have not used a board with a pre-installed shield before, so my question is if the small metal lip on the shield that is towards the back of the motherboard should be butted up against the side of the board, or actually slightly over the back of the board? Mine came with it butted up against the side, and this little bit of movement is all I should need to install the board.
3,042 Views
6 REPLIES 6

Silent_Scone
Super Moderator
Hello,

What case are you using?
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

The case is a Corsair 780T. Two other ATX motherboards fit perfectly in the case.

Silent_Scone
Super Moderator
The shroud lip should just press up against the enclosure, it's not meant to clip in. You may need to apply a slight bit of pressure to the right side of the board when lining up the stand offs, but not much.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Thanks for the reply. The larger lip that is parallel with the cutout of the case is pressed up against it tightly. I've pushed against it with a substantial amount of force, but the only movement I'm able to get out of it is the compression of the foam on the shield, and the standoffs are still too far off. I've built many PC's over the years, so I'm not afraid to use force to install a motherboard. I've had some cases that have been an issue that required excessive force to get the first couple of screws started, but the other boards I tried in this case went in with little to no force.

On the shield, the edge that goes towards the back of the motherboard is folded over to the back of the shield, and then is bent again towards the motherboard, parallel to the motherboard. This final bend is roughly 3 or 4 mm. If this lip was over the back of the motherboard, instead of being butted up to the side of it, I think I should be able to install the screws. What I don't know is if it is intended to come that way from the factory. As it sits now, the 3.5mm audio jacks are flush with the shield. Should these protrude out of the shield slightly?

HiVizMan
Level 40
Any chance you can post some high res images to show your challenge that you are facing. I have this board and tested last night in two different cases it fits no issues.
To help us help you - please provide as much information about your system and the problem as possible.

Sorry, can't post images; Already have the build done. Should have taken pictures before hand.

In case anyone else has this problem, the lip was definitely the problem. Tried to get the lip to sit on the back of the motherboard, but I ended up just grinding it flush. After that the board installed like any other, with an appropriate amount of pressure on the right side pushing towards the left to line up the standoffs.