cancel
Showing results for 
Search instead for 
Did you mean: 

[Maximus VII Ranger] M2 (Samsung 950 Pro) + SLI ?

suicidal_banana
Level 7
Hi all,

Was wondering if anybody can shine a light on this, ive recently added some new hardware to my pc, most notably a second GPU and a M2 SSD card, the added GPU (a MSI 970 Gaming 4G) works fine, but the M2 SSD doesnt appear to be detected?
I already checked my bios to make sure its set for UEFI, and it is, so im a bit clueless whats wrong?

Im aware (sadly only since after making the purchase) that the Samsung 950 Pro wont work full speed because the M2 slot on this mobo (Maximus VII Ranger) doesnt support that, but to my understanding it should still work, albeit at slower speed, id be fine with that, but at the moment, its not working at all 😞

So my question is, does anybody know if the SLI setup is affecting the ability of the M2 slot? is there anything i need (like maybe one of those M2 cards??) to get the M2 working? or should it be able to work right now?

Any help appreciated!! 😄
5,646 Views
4 REPLIES 4

suicidal_banana
Level 7
Anybody?

Black_Phoenix
Level 8
Maximus VII Ranger NVMe support was only available from BIOS 2601. You have it?

i see my account validation came through, at last...

anyhow, since i don't see my pm having recieved a reply, i'll repeat here..

in order for the system to recognize the nvme 950 pro, you need the specific samsung nvme driver installer:
http://www.samsung.com/global/business/semiconductor/minisite/SSD/global/html/support/downloads.html


i originally came in search of answers regarding a faulty sli setup, and find myself providing an answer *sigh*
anywho, take care, and enjoy your new nvme 950 pro

Jagdseelen
Level 8
Z97 chipsets only have 16 PCIE lanes and I'm pretty sure you need 8 lanes per graphic card in SLI. So that leaves no lanes spare for the M.2 drive which may be the problem.