Showing results for 
Search instead for 
Did you mean: 

Maximus VI Formula Build Problem

Level 7
So I just built my new system with a Maximus VI Formula and am having some issues. First off im no pro or even a computer guy and not sure if im even posting this in the right place. My buddy and I got it up and running but when I hook up my X52 pro joy sticks to the rear USB 2.0 or 3.0 ports it wont recognize them fully, then when I try to shut the computer down or reset it it gets to the shutting down screen then freezes up. From that point i have to manually shut off the power, then on reboot it makes it to the desk top but the keyboard and mouse wont work so I have to unplug the joysticks and manually reset the computer..I've tried all the ports on the back of the board and also re installed the joystick drivers but in order to fully do that I have to plug them in and that causes the mouse to freeze up, so once again I have to manually reset the computer..Im also having problems with AI Suite 3, I have had to re install it twice and it still gives me a application error when trying to do 4 way optimization process.. The problem doesn't stop there im also having issues with Corsair link and random freezing up of the mouse..So my question is does anybody recognize any of these problems? I also must say my SSD and HDD came out of my Asus Z77 build but not sure if that could be a issue. Please help, I really want to enjoy my new system!
My System:
Asus Maximus VI Formula
Intel i7 4770k
Corsair H80i
Corsair Vengeance 2x8GB 1600
Corsair AX860i
Asus GTX 680 TOP
OCZ Vortex 3 SSD
Windows 7 64 bit

Level 15
Welcome to the ROG forums, Stogie.

The big question here is: Are you using the same Window installation from your Z77 build or is this a clean installation?

Thanks for the quick reply Chino, So the OS is the same from my z77, my buddy who knows this stuff did say he was surprised he didn't have to anything to the OS as far as re install it again cause it looked as if everything was working. Ha! Think he was being lazy!??!

Level 15
While sometimes you can get away with swapping a Windows installation from one system to another completely different one, it is highly recommended to do a clean installation. The reason is simple. You have leftover drivers and other bits that will cause conflicts with the newer ones. Besides your new awesome system merits a new beginning.

Then I think I'll start from there! Chino, I really appreciate your fast response and I am excited to be apart of the ROG community. Ive only been gaming on a PC for around 4 months and have already upgraded from a P8z77-v, i7 3770 non K and a GTX 660ti DirectCU II to what I have now so I am really getting into it! Thanks again and I hope you wont hear 25709from me regarding these issues in the future.

Level 15

Chino, Please accept my apology for taking so long to post my solution for the issues I was having with my joysticks. So I did a secure erase of my SSD and did a fresh install of Windows 7 only to have the problems persist. I did however find the solution to this issues on this forum but cant find the thread in order to add the link here but I do remember its title "How do I disable or delete the USB 3.0 drivers?" and the solution that was posted came from Praz. The Solution is as follows "In UEFI go to Advanced>USB and try setting xHCI to disabled" this solution worked great for me. So If people in the future are have issues with z87 and Saitek X52 joysticks this seems to fix the problem. Once again thanks for your help and welcoming me to the ROG community! Stogie

Level 40
Nice system mate, do not spoil such a sweet rig with an old and dirty OS. Go on and install a fresh version you know you want to.

😄 😄

Just do make sure you have your data backed up.
To help us help you - please provide as much information about your system and the problem as possible.

Level 7
I'm having same issue with asus rog maximus VI extreme. I dont want to modify the bios settings. So, i decide to sell this bull**** saitek's joystick and buy a warthog.

3Shadow3S wrote:
I'm having same issue with asus rog maximus VI extreme. I dont want to modify the bios settings. So, i decide to sell this bull**** saitek's joystick and buy a warthog.

Its a real simple thing to do but it may cause Compatibility issues with other devices. You did the right thing buying a nicer set of sticks. I doubt Asus or Saitek would ever fix this problem.