Showing results for 
Search instead for 
Did you mean: 

how long does ittake to update BIOS?

Level 7
I am putting together a Hero IX.

I used the flashback button to load a new BIOS. I put in a thumb drive with the renamed BIOS in the root. I pushed the button until it started blinking. It quickly went to a solid on light.

It has been more than 45 minutes and the light on the button is still solid.

That does not seem reasonable. I am concerned about simply stopping it.

Level 7
I am getting nowhere. After letting it go for an hour, no change. BIOS is still at 801. Update is to 906.

Level 13
Lit solid is not active. It should be flashing when updating.
Format USB to fat 32 and have nothing on it but the bios you want to use. Should be named M9H.CAP for your board.
Make sure you have the USB in the correct USB port, only one is labeled BIOS
Make sure you have loaded optomized defaults in your current BIOS
Push and hold the MOBO connect button until it starts flashing then let go.
It generally takes around a minute or so. A few seconds usually means the USB is not in the correct USB port, the file name is incorrect or the USB inst formatted or has other stuff on it besides the single CAP file (should be nothing else) Also try and use a small capacity USB.

“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein

Level 15
The USB BIOS Flashback process usually takes one to two minute. The light staying solid means the process has completed or failed.

If your system is working fine, you can update the BIOS through the EZ Flash Utility inside the BIOS. There's no need to use the USB BIOS Flashback features. 😛

Level 40
Hi alternety2 🙂

Maybe try this on the pendrive and try BIOS Flashback again...

Light should flash for over a minute...

I have it resolved. At least part of the problem was incorrect info (or my lack of understanding of what it said) in the manual.USB BIOS Flashback did not work as expected. It specifies the extracted bios file to be properly named and put in the root directory of the USB drive. It does not specify the USB drive must be empty of every thing else. Did that; Turned off machine; Placed drive in specified port; Pushed the button; Got the flashing light; flashed and then went to steady on. Never went out, bios not updated.

Using the function while in the BIOS worked beautifully and actually updated the BIOS. I will use that procedure whenever I need to update the BIOS. Way better interface/process.

A side note on bios files. I got 906, from I believe the global site. The latest in the US was 8 something. I have been unable to figure out how to force getting to the global site. Link anyone? I suspect I overwrote a number of my downloaded driver files because of this.

Now all I have to do is figure out how to install a flaky Win 10, previously an update to a licensed Win 8.1, on another motherboard, to work on the new MB long enough to get an update of Win 10 Anniversary to run and wait for MS to screw it up. MS unsuccessfully tried 12 updates: all failed. Four hours on the phone with level one and level 2 reduced the Win 10 to rubble. I need to keep programs and data. Therein lies the demons. aaarrrggghhh. It has been weeks.

Level 7

 Ok heres what I did to solve the problem. Use another pen drive brand. It work for me for example ScanDisk. 

I write it down before I forgot and look again for the same problem. 😂