cancel
Showing results for 
Search instead for 
Did you mean: 

Fixing bios do not update

Jobbe1986
Level 8

Impossible update bios from 816 to 904 or 2102 asus z790 hero please help NEEd ultimate bios for ddr5 ram 

660 Views
12 REPLIES 12

Nate152
Moderator

Hello Jobbe1986

Follow this video to rename and put the bios file on your usb flash drive.

Once you have the bios file on your usb flash drive, follow these steps.

1) Shut down your pc and let the psu switch on.

2) Insert your usb flash drive into the usb port marked "BIOS".

3) Press and hold the Bios Flashback button until it starts blinking, then release.

4) When the blinking stops, the bios update has completed.

5) Start your pc and the update process will finish.

Z790 Hero Bios.png

 

 

 

 

This procedure has been performed a hundred times the pc does not start with a bios other than 813/816 it will remain a mystery asus indefinitely I just have to buy another motherboard

Nate152
Moderator

I will advise to try again and follow the steps exactly. You can try resetting the bios to default settings (In the bios, hit the F5 key), then shut down your pc and try updating.

 

 

 

 

 

 

Yes friend thank you for the time spent making the video, this procedure has been performed an infinite number of times without success at the end of the update (performs all the step update area 1 etc.) it says that the installation has been successfully completed and I system will be restarted ok. restart runs the verification leds red, red, white green for a fraction of a second I can see that the keyboard is activated and the monitor has a gasp as if it were starting the q-code marks code 98 then b4 and after the boot sequence starts again to infinity I tried to let it go but after an hour it always repeated the same things, I insert the key with the bios 816 behind the motherboard I press the flash bios button and strangely with that bios everything works again I repeat I can not put anything even the 904 only 813 or 816 I read online that there are also other people with this problem and it has never been solved

I also tried to unplug all internal and external usb headers do a cmcos remove the battery set bios by default remove ram I tried them all really another curious thing was to set optane memory instead of hyper rog in an option I don't remember where this made the video card work at pcie 4x16 otherwise it worked at 4x8 (it took me 3 months to find out) full of bugs this card I don't know you others how do you update the bios maybe it's my card that is failed I've never had similar problems to run such an easy thing incredible there must be something broken from bios 904 on but I don't know what is frustrating

PLease take this the right way

1. octane memory was close in 2022 by intel. there is no support on drivers and much less on new board z790/z790v2. I think with a hard work you can use that on z690 with very old bios on 12th gen cpu ONLY  the intel 13 and 14 gen does not support octane  by dye. you can check intel resources and a little work i get the data in 67seconds.

2. i do not know the board you have but i am 100% sure that there is something missing that is not being done. Like, format a usb stick UP TO 32gb in fat32 and the video. NOTE: board trend to not like the usb stick. And only has to be use as it is.Bios can be updated direct on bios  as

With more data i can help any q let me know

Learn, Play Enjoy!

 As for optane I know, in fact it is a bug in the motherboard bug if I change this option allows the video card to boot to pcie 4x16 leaving out this I formatted the stick in fat 32 and I also used asus flash z directly from the bios guys it does not work I know how to update a bios so it is the unlucky motherboard or there is something that does not allow you to update currently I am to version 816 I have an asus z790 hero if I want to put the older bios 813 works but if I want to put 904 installs it but it crashes on the boot cycles does not get to the led boanco of the video card stops in green with b4 code (usb legacy) and there is no way to continue the only thing I have not tried is to change monitor but I do not think it is connected to the problem lately I have changed TV and it also with this new

Sorry for english 😂

Vialli
Level 8

Go into your bios and upgrade it from there..