cancel
Showing results for 
Search instead for 
Did you mean: 

d0 error code and pc turns on and off

Binbose
Level 7
Hi,

I just finished assembling my (first) system, with the following components:

MOBO - Asus prime X399-A
PSU - Seasonic Focus Platinum 750 W
GPU - GeForce GTX 1080 Ti (First PCIe Slot)
RAM - BALLISTIX BLS16G4D240FSB 16 GB (single stick, in second slot from the left on the right (A1))
SSD - Samsung 960 Evo M.2 (under the cover)
HDD - None
CPU - Threadripper 1900x
CPU Cooler - Arctic TR Version

Now the first time when I turned on the power, the mobo lighted up, und the chassis fans start to spin. The Q code went shortly through some different codes, then stayed for 1-2 seconds on "d0" and then changed to "Ad" but no signal whatsoever on the screen (and cpu cooler doesnt started to spin, idk if it is supposed to when booting). The led on the top right (when in the case) turns yellowish and the one on the bottom right turn orange/red.
I tried to troobleshoot it by reseting the CMOS by placing a metal object on the two pins, short circuiting it .
Now it changed and the system goes straight to "d0" and turns on and off continously, till I press the power button for 4 seconds.
I never build a PC before, so I have no idea how to troobleshoot this.

Best regards

Edit 1:
I removed every part except the CPU and the RAM, and the Problem remains.

Edit 2:
After removing the RAM completely the PC is not stuck in the infinit boot loop anymore, and instead shows the Q Code "C0" (which is weird, because I cant even find this code in my manual).
11,211 Views
10 REPLIES 10

davemon50
Level 11
Make sure you've connected your cpu fan to the CPU_FAN header on the board. The CPU fan should run when powered on. Try also disabling CPU fan speed control in the BIOS (at first) to ensure it comes on at full speed. After you get it working you can enable to control for temp.

In connecting your CPU, make sure you did not overtighten the screws, and that they are torqued pretty evenly.

Make sure you recall putting thermal paste on the copper fins. Check also that you don't have any excess thermal paste overrunning that connection (too much on there, squeezing out).

You may need to pull the CPU out and reinstall it again. Check for damage.

You can try with a single RAM stick in the appropriate location, but not with zero RAM sticks.


So.....that's just going down the avenue of checking the CPU integrity, but also you might want to take a look at your power supply and those connections too. Make sure all firm connections and that they're all there. PSU fan spinning ok?
Davemon50

Hello davemon50, thank you for the response.
Connecting the CPU fan didnt make a difference. Unfortuanately I cant even go into the BIOS, as I dont get a signal, and the PC turns off after a few seconds (and back on and off again and so on).
I looked closer at the POST LED state, and it indicates, that there is a problem with the DRAM.

I also checked the CPU pins, and everything looks fine to me. Also the CPU itself doesnt seem to have any damages/scratches etc.
Thermal pase is also applied and no overflow.
I could try to loosen the screws a bit, but I dont think it is too hard.

I checked all PSU connections, and they are all tight.

davemon50
Level 11
Check your RAM stick slot according to your users manual. The way I read your manual you need to put it in the 3rd slot from the right, which is gray in color. Your initial post above says you put it in the 2nd slot from the right. Could just be the way it is stated, but counting starting at 1, 2, 3, when you get to 3 put it in that slot.


And also, I don't understand what you mean by connecting your fan makes no difference. Are you saying you didn't connect your fan? (Obviously you must).
Davemon50

Sorry I wrote that misleading and corrected it. It is on the right side of the CPU in the second slot counting from left (1, 2, 3, 4). Here is an image 73781

By connecting the fan makes no difference I just mean, that the same problem persists when I am plugging in my CPU fan.

davemon50
Level 11
There is a May 2nd BIOS update for your board that you should ensure you have installed. There are apparently some issues similar to yours that may be related to old AGESA by AMD. On Asrock forum you can see a thread like that HERE. Try that.

And just to be sure reseat your RAM a few times really firmly.
Davemon50

Mh, putting the memory stick into the far most right slot worked, now I can enter the BIOS. However, does that mean that the A1 RAM slot is broken or can it have different reasons?

davemon50
Level 11
That is something you would have to consult with Asus on, directly. I have never seen the users manual instruct on the wrong memory slot before, and it is seemingly always in slot A1 from what I've seen. If it works in the other slot, maybe you need to relearn the memory. Clear CMOS and start over perhaps using A1.
Davemon50

Ok, I will call them tomorrow.
Thank you very much for the advices though.
Best regards!

davemon50
Level 11
Good luck, let us know how things turn out.
Davemon50