Showing results for 
Search instead for 
Did you mean: 

Crosshair VIII Dark Hero failing to post with d6 error and showing the white led

Level 7
I have Crosshair VII Hero, with 64GB (4x16) DDR 3200 Corsair memory, 2 x 1TB M2s, Ryzen 7 2700X and an LSI 9260-8i (32TB), Asus STRIX-GTX1070-8G-GAMING, with 2 monitors connected via DP and HDMI.
I run Mint Linux and Windows 10 for Steam games, it has been stable for years.

I upgraded this system with a Ryzen 9 5950X, and everything was fine, I then decided to rebuild my daughter's PC giving her the 2700X and I would get the Dark Hero.

The Crosshair VII Hero, with 16GB (2x8) DDR 3200 Corsair memory, 1TB M2's, Ryzen 7 2700X, Asus GTX 770 - All okay and working.

At this point, I know that everything is working, all of the hardware except the Dark Hero, So I build the same system as I had before but based on the Dark Hero.
The first (and many) power on's fails d6, white and green LED. Lots of unplugging and plugging, swapping DIMMs, removing DIMMS, swapping graphic cards, removing cables,m nothing worked. I had also ordered a Ryzen 5 5600X as I was going to build a PC for my wife, I replaced the CPU and nothing.

After this, I unplugged the DP port and once it booted, I went into the BIOS and the version was Version 3801, I updated the bios to 4006, after the reboot back to the same thing and more days spent trying.

I then put the GTX 1070 into the other system and found this, it updated the firmware on the card, this then went back into the new system, it did boot a few times, but was not consistent and still gave the graphics card error.

Another day later (left overnight unplugged) it booted, I then went into the BIOS and looked around and noticed under the Advanced settings (I will get the full path and add it soon) there is an option for setting the PCIE slots to auto, G4, G3 G2. I changed the setting to G3 and since then it has booted every time and I have not had any issues, the next thing is to go back to the Ryzen 9 5950X.

I am guessing that older cards do not support Gen4 PCI and maybe there is an auto-detect issue.

If you upgrading to the Dark Hero and have an older card that does not run at PCI 4 speeds I would do this:
1) Update the graphic card's firmware before you start.
2) Plug into the HDMI port leaving the DP empty.
3) Have a USB stick ready with the latest BIOS.
4) Boot the PC with 2 DIMMs if you are using larger DIIMs
5) As soon as you can get into the BIOS set the top PCIE slot to Gen3 from Auto.
Advanced -> Onboard Devices Configuration ->PCIEX16_1 Mode = Gen3

I am yet to see what happens on the next BIOS update, but at least I know that today everything works.

I hope this helps someone and saves them days of fault-finding.