cancel
Showing results for 
Search instead for 
Did you mean: 

Confused about Intel Rapid Storage Technology vs. AHCI for NVMe M.2 SSD

S_D__Plissken
Level 8
Dear Forum,

I just got done building my first PC in a long while and things have changed considerably since the 1990s. I am running a Samsung 960 Evo NVMe M.2 on a ASUS Maximus IX Code. I am a bit confused as to what SATA Mode I should use to run for best performance, in fact I have no clue.

My Mobo offers two options with regards to SATA controllers:

1) AHCI

2) Intel Rapid Storage w/ Optane support (RAID)

I do not intend to the NVMe as part of a RAID array, however I do want the best performance. Not knowing any better, I chose Intel Rapid Storage w/ Optane support (RAID). It has the word "rapid" in its name after all…
I succesfully managed to install Windows 10 and so far things are running fine. Is there any reason I should bin my installation and set the SATA controllers to AHCI instead? Are there any drawbacks to choosing Intel RST over AHCI?



Bonus question: Should I disable CSM (compatibility support mode) in the UEFI Boot options?



Your input is most appreciated!
184,943 Views
11 REPLIES 11

CODE_MAXIMUS
Level 11
S.D. Plissken wrote:
Dear Forum,

I just got done building my first PC in a long while and things have changed considerably since the 1990s. I am running a Samsung 960 Evo NVMe M.2 on a ASUS Maximus IX Code. I am a bit confused as to what SATA Mode I should use to run for best performance, in fact I have no clue.

My Mobo offers two options with regards to SATA controllers:

1) AHCI

2) Intel Rapid Storage w/ Optane support (RAID)

I do not intend to the NVMe as part of a RAID array, however I do want the best performance. Not knowing any better, I chose Intel Rapid Storage w/ Optane support (RAID). It has the word "rapid" in its name after all…
I succesfully managed to install Windows 10 and so far things are running fine. Is there any reason I should bin my installation and set the SATA controllers to AHCI instead? Are there any drawbacks to choosing Intel RST over AHCI?



Bonus question: Should I disable CSM (compatibility support mode) in the UEFI Boot options?



Your input is most appreciated!


That is a PCIe Gen3X4 storage device. You are going to get maximum performance from running the device through PCIe @ 4X bandwidth. If that is the only device you plan on using for storage configure it under ONBOARD DEVICES CONFIGURATION in BIOS for M.2_1 Configuration: Set to PCIE Mode and for M.2_2 PCIe Bandwidth Configuration set to X4. IRST is for setting up Raid arrays (setting up 2 or more drives for faster performance or larger capacity or both), AHCI is for SATA only drives. PCIe is for NVMe devices like what you have. You don't have an Optane drive so your not configuring that either.

Page 3-18 in your book (I have the Maximus IX Code mainboard also) with Toshiba RD400 NVMe storage device, same as you just Toshiba not Samsung.

With my system since I have no SATA devices connected to it I have the SATA controller disabled in the BIOS under PCH Storage Configuration (page 3-17 in book)

Now after you get that configured and you are back in windows you can install Samsungs driver for that device verse using Windows version and you'll probably get a little bit of more performance from it as well. Also make sure you install the Magician software.

http://www.samsung.com/semiconductor/minisite/ssd/product/consumer/960evo.html

CODE MAXIMUS wrote:
That is a PCIe Gen3X4 storage device. You are going to get maximum performance from running the device through PCIe @ 4X bandwidth. If that is the only device you plan on using for storage configure it under ONBOARD DEVICES CONFIGURATION in BIOS for M.2_1 Configuration: Set to PCIE Mode and for M.2_2 PCIe Bandwidth Configuration set to X4. IRST is for setting up Raid arrays, AHCI is for SATA only drives. PCIe is for NVMe devices like what you have.

Page 3-18 in your book (I have the Maximus IX Code mainboard also) with Toshiba RD400 NVMe storage device, same as you just Toshiba not Samsung.

With my system since I have no SATA devices connected to it I have the SATA controller disabled in the BIOS under PCH Storage Configuration (page 3-17 in book)


Thank you very much for your comprehensive reply!
A couple of follow up questions though:

1) For now that is indeed the only drive I plan on using. I might want to add a slower SATA SSD for storage / games in the future. Will changing the settings similar to yours hamper my ability to do so? I assume that I can always reactivate the SATA controller in the UEFI.

2) Will I need to reinstall Windows after changing the settings?

Thanks a lot in advance.

S.D. Plissken wrote:
Thank you very much for your comprehensive reply!
A couple of follow up questions though:

1) For now that is indeed the only drive I plan on using. I might want to add a slower SATA SSD for storage / games in the future. Will changing the settings similar to yours hamper my ability to do so? I assume that I can always reactivate the SATA controller in the UEFI.

2) Will I need to reinstall Windows after changing the settings?

Thanks a lot in advance.


No they won't as you've already installed windows on that device, yes you can always enable the SATA controller but it will only be used as a stand alone storage device like a USB flash drive since the SSD you plan to add down the road wasn't configured with the windows installation you've already done.

As far as will you need to reinstall windows if you change these settings I gave you above for your current configuration the answer is no. Leave your SATA device enabled, once you change to PCIE for M.2 and change the bandwidth to X4 that will put the drive in PCIe where it should be. You don't have to disable the SATA controller, I just do it because I'm not using anything connected to the SATA ports.

Your welcome, np.

CODE MAXIMUS wrote:
No they won't as you've already installed windows on that device, yes you can always enable the SATA controller but it will only be used as a stand alone storage device like a USB flash drive since the SSD you plan to add down the road wasn't configured with the windows installation you've already done.

As far as will you need to reinstall windows if you change these settings I gave you above for your current configuration the answer is no. Leave your SATA device enabled, once you change to PCIE for M.2 and change the bandwidth to X4 that will put the drive in PCIe where it should be. You don't have to disable the SATA controller, I just do it because I'm not using anything connected to the SATA ports.

Your welcome, np.


Thanks again for your advice. I set it up exaclty like you did, deactivating the SATA controllers for now. It works perfectly well.

S.D. Plissken wrote:
Thanks again for your advice. I set it up exaclty like you did, deactivating the SATA controllers for now. It works perfectly well.


Since it is a PCI express device you might as well use it as one, that's the purpose for it, more performance, 4 times the speed of SATA. Glad everything is working for you, did you install Samsungs NVMe driver as well? It should be executable so you don't have to change it manually, at least TOSHIBA's was.

Yes it is executable, eezy peezy, just click the program and let it do it's magic.

http://www.samsung.com/global/business/semiconductor/minisite/SSD/downloads/software/Samsung_NVMeDri...

64115

CODE MAXIMUS wrote:
Yes it is executable, eezy peezy, just click the program and let it do it's magic.

http://www.samsung.com/global/business/semiconductor/minisite/SSD/downloads/software/Samsung_NVMeDri...

64115


Yes, I installed the driver from Samsung without trouble. No issues so far!
But I just realized something else: the PCIE Speed setting (M.2_2) has reverted to x2 mode in the UEFI. And every time I set it to x4 it seems to do so automatically. I change the setting then choose safe and restart. The system will then restart itself (screen stays black for a couple of seconds). The next time I enter the UEFI, the setting is back to x2.
Apart from my Graphics card and the drive, I have no other device installed. Any idea what could be the issue there?

PS. Actually, nevermind. I am operating my drive in the M.2_1 slot (the one under the cover). So I assume that according to the manual (page 3-18), the option M.2_2 (auto/x2/4) only relates to the M.2_2 slot. As I my drive sits in slot 1, it probably autodetects PCIE speed.

I just benchmarked the drive in Samsung magician and I get the following results:

Sequencial Speed read: 2,682 MB/s
Sequencial Speed write: 1,771 MB/s
Random (IOPS) read: 401,667
Random (IOPS) write: 349,515

Also, Magician reports PCIE Gen. 3 x 4 as Interface on the start Page.

I think these results look alright!

S.D. Plissken wrote:
Yes, I installed the driver from Samsung without trouble. No issues so far!
But I just realized something else: the PCIE Speed setting (M.2_2) has reverted to x2 mode in the UEFI. And every time I set it to x4 it seems to do so automatically. I change the setting then choose safe and restart. The system will then restart itself (screen stays black for a couple of seconds). The next time I enter the UEFI, the setting is back to x2.
Apart from my Graphics card and the drive, I have no other device installed. Any idea what could be the issue there?

PS. Actually, nevermind. I am operating my drive in the M.2_1 slot (the one under the cover). So I assume that according to the manual (page 3-18), the option M.2_2 (auto/x2/4) only relates to the M.2_2 slot. As I my drive sits in slot 1, it probably autodetects PCIE speed.

I just benchmarked the drive in Samsung magician and I get the following results:

Sequencial Speed read: 2,682 MB/s
Sequencial Speed write: 1,771 MB/s
Random (IOPS) read: 401,667
Random (IOPS) write: 349,515

Also, Magician reports PCIE Gen. 3 x 4 as Interface on the start Page.

I think these results look alright!


Super awesome this turned out a plus for you. You got it! Note about being under the armor (cover) 1) The controllers on these NVMe devices can get pretty warm by themselves 2) being under the cover doesn't help any other than aethetics and keeping dust off the board 3) (which is the most) is that it is right next to the PCH chipset and that gets pretty warm itself so that adds along with the heat that's already building up from the NVMe drive. Just some food for thought. I had my Toshiba RD400 in there and it got to 77 celcius pretty quick verse being on the vertical M.2_2 socket which was alot better as the front intake case fan supplied adequate air flow over it to keep it cool (averages about 50c) . Check the operating temps for your drive and make sure your not exceeding the temps because the drives will throttle performance due to thermals not to mention heat is never good for sensitive electronics which adds degradation of the device. If you do move it make sure you power off power supply first or unplug it.

Here's my speeds from toshiba benchmak (no ram caching of drive) straight performance. 512GB drive.
To convert MBps to IOps you use the formula;

IOps = (MBps / 4) * 1024

So my speeds are;

Sequencial Speed read (128KB): 2,310 MB/s
Sequencial Speed write (128KB): 1,520 MB/s
Random (IOPS) read (4KB): 230,620
Random (IOPS) write (4KB): 132,272

64145

JustinThyme
Level 13
Firstly SATA and NVMe have nothing in common. Your BIOS setting is either enabling or disabling the Intel raid hardware raid controller then you have the ability to choose what is enabled and what is disabled. I have my raid controller enabled because I am using it on two 1TB 850 evos and it effectively doubles their speed.

I however have it disabled on the M2 slots and PCIe_4.

Samsung drivers make no dicernable performance difference over windows default NVMe drivers. This has been proven over and again so its your choice but you dont have to use them. I choose not to as if you do put them behind a raid controller by design the Samsung software cant see past the controller because they haven't bothered to develop their drivers or software since the introduction of the 840 evo.

For performance benchmark the most widely used is Crystal marks.

Your 960 Evo should be getting around 3000Mbps sequential read regardless of the drivers used.



“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein