cancel
Showing results for 
Search instead for 
Did you mean: 

Can't run Nvme drive as PCIE3 (stuck at PCIE x2)

Aenra
Level 7
Hello,

I have an X99 Deluxe II and i'm having trouble running my Samsung 960Pro correctly.
Specifically, drive is recognized and bootable.. but no matter what i do, Samsung Magician 'recognizes' it as a PCI express 2.0 x4, resulting in a maximum read of 1.8K (well below its potential). Ideally, it should be run as PCI express 3.0 x4.

Now, to help anyone out:
- Latest drivers, so it's not that. BIOS, OS, the Nvme itself, all up to date.
- My drive is mounted on a platform that's installed ON the PCIExpress slots. It is -not- installed in the motherboard's vertical socket.
(have tried two different platforms just to be sure, my old one and the bundle-included HyperX module, same issue).
- Have had the same problem whether i mounted the drive at PCIEx16_3 (slot 4 going down), or PCIEx16_5 (slot 6).
- In case you're wondering about lanes: GPU at PCIEx16_1 (slot 1), sound card at PCIEx16_2 (slot 3). Everything else unoccupied.
- In the BIOS, under "NB PCI-E Configuration", all slots are set to run as gen3
- In the BIOS, under 'OnBoard Devices Configuration', "U.2_2 Bandwidth" was set to Auto when i tried mounting it at (slot 4)PCIEx16_3.
- In the BIOS, under 'OnBoard Devices Configuration', "PCIEx16_5 Bandwidth" was set to 4x when i tried mounting it at (slot 6)PCIEx16_5.
(tried 8x, wouldn't even see the drive. So at x4).
- Was advised elsewhere to turn the SLI switch to 3, mount gpu at 1, nvme at 3, sound card at 5, see if that forced the damned thing to run it at the proper speed. Again same issue, shows as 2.0 x4..

Am i doing something wrong? Have had this drive on a different X99 chipset mobo, i know it can run at 3.0 x4 just fine.
Any help would be appreciated.
4,298 Views
4 REPLIES 4

Chino
Level 15

Chino wrote:
Have you tried benchmarking your drive with the latest version of CrystalDiskMark?


Thanks for replying @Chino
Will give it a shot, though to be fair? As mentioned, have had the same drive under the exact same software in a different x99 mobo. Software showed it as 'x3.0' there, same software benchmarked it around 3+K there instead of 1.8K here. Doesn't stand to reason it's the program (since it's the exact same version), but will try anyway 🙂

Assuming you're still reading, it has been mentioned elsewhere that it might be the mobo itself; ie that the actual chip on it is a PCIExpress 2.0?
Any info on that?

Any 'official' response please?

I'm having the exact same issues with my x99pro. All of the documentation claims the drive is suppose to run at up to 32gbs which would indicate 3.0 x4 (8gbs per lane). However after looking at Sandra and HWINFO it shows i am only running at 2.0 x4 and crystaldisk benchs at around 1850gbs (2.0 speeds) I have a WD Black SN750 with advertised speeds of 3470write and 3000read. I have searched through every setting in the bios and there are no setting for m.2 or nvme any where. I have an intel xeon e5-2680 with 40 lanes on the north bridge (board is configured correctly). What gives? Is this a windows driver issue? im running the standard nvme widows driver. Have searched high and low for a western digital or sandisk driver with no luck. Please Help